Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i am trying to configure an apache2 server with mod_fastcgi on solaris 10 so far i have everything installed using CSW

here is my virtual host configuration

<VirtualHost X.X.X.X:80>
SuexecUserGroup "#1005" "#1006"
DocumentRoot /home/testwh2/public_html
ScriptAlias /cgi-bin/ /home/testwh2/cgi-bin/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory />
SetHandler fastcgi-script
Options +ExecCGI
Order Deny,Allow
Allow from all
</Directory>
FastCgiServer /export/httpd/cgi-bin/php
</VirtualHost>

/export/httpd/cgi-bin/php is a hard link to my php interpreter

and here are my errors log

FastCGI: comm with (dynamic) server "/home/testwh2/public_html/test.php" aborted: (first read) idle timeout (30 sec)
[Fri Aug 17 12:32:27 2012] [error] [client X] FastCGI: incomplete headers (0 bytes) received from server "/home/testwh2/public_html/test.php"
[Fri Aug 17 12:40:12 2012] [error] [client X] FastCGI: comm with (dynamic) server "/home/testwh2/public_html/test.php" aborted: (first read) idle timeout (30 sec)
[Fri Aug 17 12:40:12 2012] [error] [client X] FastCGI: incomplete headers (0 bytes) received from    server "/home/testwh2/public_html/test.php"

thanks

EDIT: fixed using this http://www.trilithium.com/johan/2005/04/apache2-fastcgi/ , just need to suexec the thing

share|improve this question

1 Answer 1

up vote 0 down vote accepted

removed FastCgiServer directive and now it is working perfectly , will post config soon for reference

/etc/httpd.conf

LoadModule fastcgi_module     libexec/mod_fastcgi.so

<IfModule mod_fastcgi.c>
        FastCgiWrapper /opt/csw/apache2/sbin/suexec
        FastCgiconfig -maxClassProcesses 1 -singleThreshold 1 -autoUpdate -idle-timeout 240 -pass-header HTTP_AUTHORIZ
ATION
        AddHandler  fastcgi-script              .fcgi .fcg .fpl
</IfModule>

vhost config ScriptAlias /cgi-bin/ /home/testwh2/cgi-bin/

<Directory "/cgi-bin/">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>

/home/testwh2/cgi-bin/php5.fcgi

#!/bin/bash
export PHPRC="path/to/php.ini"
export PHP_FCGI_CHILDREN=20
export PHP_FCGI_MAX_REQUESTS=5000
exec /usr/local/fc_wrap/php5 "$@"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.