Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Visual AND audio bells are incredibly annoying. I DON'T CARE that I hit backspace 3 times when there were only 2 characters in the terminal! I KNOW you can't tab-autocomplete because I can see that you HAVEN'T DONE IT!

I want NO BELLS! Of any variety! All the solutions I see online are to turn the visual bell on or off, which inversely turns the audio bell off or on. I want NEITHER BELL!

This is on Ubuntu 12.04 in screen.

Edit

It's not the "BEEP!" from the speaker on the motherboard or whatever. It's a "Boink!" sound, clearly a pre-recorded sound effect.

Edit Edit

Alright, apparently this question doesn't belong here. In case anyone discovers it on the internet anyway, I got what I wanted by turning off the visual bell (which turns on the audio bell) and then also going to System Settings -> Sound -> Sound Effects -> Selecting both mute check boxes.

Sheesh.

share|improve this question

closed as off topic by Chris S Aug 17 '12 at 15:52

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

9  
So it's safe to assume you don't like the bell... –  DKNUCKLES Aug 17 '12 at 15:47
1  
See superuser.com/questions/15770/… –  Chris S Aug 17 '12 at 15:53
    
@ChrisS Are you trying to tell me this question belongs in superuser? –  Dave Aaron Smith Aug 17 '12 at 15:57
    
@DaveAaronSmith He's telling you that it's a duplicate of a question from super user (but yes it does belong in Super User –  DKNUCKLES Aug 17 '12 at 15:58
    
Or even on askubuntu.com –  squillman Aug 17 '12 at 16:03

2 Answers 2

try

setterm -blength 0

man setterm

share|improve this answer

You have two options as far as I can see it

share|improve this answer
1  
It's not the internal speaker. It's this "Boink!" sound. "Boink! Boink! .... Boink!" –  Dave Aaron Smith Aug 17 '12 at 15:50
    
superuser.com/questions/15770/… –  DKNUCKLES Aug 17 '12 at 15:51
    
If it's not the pc speaker, then you're not just "in screen", you're "in screen in some sort of terminal". That "some sort of terminal" has the setting for what to do with a bell, for instance PuTTY has an entire screen of options under "Bell". –  DerfK Aug 17 '12 at 15:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.