Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using two TP-Link WA-5210G, I am trying to create a network bridge between two networks, netA and netB. I want to share my internet connection from netA to netB, using the AP from netB.

netA :: Wireless ADSL modem / router : 192.168.1.1
        DHCP disabled
        Wireless AP in client mode, LAN connected with ADSL router @ 192.168.1.254

netB :: Wireless AP in AP mode : 192.168.1.253
        DHCP disabled
        Other wireless clients with static manual IP addresses

For default gateway and DNS at the clients in netB I set the IP of the modem / router, 192.168.1.1, and I have confirmed that a client can ping the router. But still no internet. What remains to be done?

share|improve this question
    
Have you logged into netA and pinged any IP/domain on the internet? –  Chida Aug 17 '12 at 18:07
    
I send this message from netA right now, netA has internet access. But when I try to ping from my computer in netA to say www.google.com, I get a request timeout although the DNS resolution works fine. Weird. –  dtouch3d Aug 17 '12 at 18:32

2 Answers 2

Either connect the netA and netB devices with a physical cable or the netB device needs to be set to be a client of netA (either directly in client mode or via an extend-a-network mode or however TP-Link specifies it).

share|improve this answer
    
Physical cable is not an option, the two networks are about 7 km away! netB in client mode was the initial working configuration but I had to change it. Why doesn't it work now, especially when it can find the router? –  dtouch3d Aug 17 '12 at 22:06
    
Because the two AP's are running independently of one another - there's no notion of how to bridge a packet from one to the other. One of the devices works as an AP, the other as a client. –  rnxrx Aug 18 '12 at 0:59
    
I still don't get it. What do you mean by saying "bridge a packet"? Since any device in the network connects to the router, the gateway and DNS settings should be enough. What if I add a static route to my router? –  dtouch3d Aug 18 '12 at 9:54
up vote 0 down vote accepted

I had used 802.11g for the wireless link. I switched to 802.11b and the connection is as stable as rock. No packet loss.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.