Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a saved .RDP file for a connection to another computer, if I check the box to "Remember my credentials" the connection attempt is immediately rejected and the authentication box pops back up immediately. I also can't save the credentials in Remote Desktop Connection "Edit" mode.

I had read that the credential saving is impacted by your computer being joined to a domain or not, as well as some group policy settings that control various aspects of stored credentials. I opened the Local Computer Policy -> Computer Configuration -> Administrative Templates -> System -> Credentials Delegation policy and saw that all the policy elements were set as "Not configured". I changed all of them that had NTLM-only as well as the "Allow Delegating Saved Credentials" policies to enabled and added an entry to the servers list of TERMSRV/* for each.

authentication prompt

group policy

Is there something else I may have missed? I did a gpudate /force after changing the policy, as well as a courtesy reboot to see if it made any difference. There is nothing in the domain group policy that is forcing these options (that I could find anyway).

Disclaimer: this computer has Sophos SafeGuard 5.5 installed which takes over / augments a lot of the default authentication prompts. It could very well be part of the Sophos virus that is ignoring the policy or has a separate configuration.

share|improve this question
    
Credential delegation provides a way to bypass password prompts altogether, but shouldn't affect whether you may save a password. Have you checked your password vault to see whether a password was already entered for that end point? –  Michael Steele Nov 30 '12 at 23:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.