Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I installed TFS2012 the other day and now when I try to view the web access app I get the error as shown below. Ideas?

TFS 2012 server error

share|improve this question
From the stack, it looks like a compatibility problem between your machine and TFS. What version of IIS are you running? Did you get any warnings during the install? (You can search the install logs for "[warning]" if you can't remember) – Russ Amos Aug 20 '12 at 14:01
I actually used the web access portal for an hour or so. So I'm sure it's not a corrupt installation. – Naeem Sarfraz Aug 21 '12 at 12:16
Have you tried repairing TFS via Add/Remove programs > TFS > Change? It may have worked immediately after installation, but it looks like it has been corrupted in the intervening time... – Russ Amos Aug 21 '12 at 12:26
TFS2012 doesn't have repair option – Naeem Sarfraz Aug 21 '12 at 12:30
I'm glad you found a solution. The installer does not have a repair option, but you can repair via Add/Remove Programs. – Russ Amos Aug 21 '12 at 14:26
up vote 1 down vote accepted

Create a global.asax file in the C:\Program Files\Microsoft Team Foundation Server 11.0\Application Tier\Web Services folder with the following content:

<%@ Application Inherits="Microsoft.TeamFoundation.Framework.Server.TeamFoundationApplication" %>

Seems like something went wrong after I used the web access tool and the global.asax file went missing from the web services folder. Discussion from the TFS forums.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.