Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a very strange situation and do not know where to look. I have a XEN installed on Ubuntu 12.04 LTS. My hosting-provider does require, that every new IP my server uses has an own MAC-address. Therefore I use a bridged interface xenbr0.

Now the VERY strange thing:

I assign the mac-address to a virtual interface of a virtual machine with Windows 7, it does say "no network connection" - I used dhcp, then entered gateway,netmask&ip manually, flushed ARP cache. Nothing. It still has no connection. I can not ping the gateway.

I assign the same mac-address to a virtual interface (the virtual interfaces are identical) of a virtual machine with Ubuntu 12.04, this does get the IP via DHCP, suggests the PTR record of the IP as hostname etc. - quite strange.

This is very strange for me, as I tried to assign the same (and different) MAC's also to a pfSense machine (FreeBSD) and I had the same result as on Windows 7, even if I set up everything manually, the server can not ping the gateway.

What does Ubuntu do, what makes it work? Or where should I start looking?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.