Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to set up a Lexmark C543dn laser printer onto our office wired network.

Our office is around 60 computers, all connected to a server, each PC has a static IP. (Some IP's aren't allowed full web access, just certain sites).

First worry is that on plugging in the ethernet the green lights don't illuminate. I can print directly from a computer if using USB.

I'm trying use a manual IP and netmask/gateway. (,,

The network report page you can print out states: Status: Not connected

Checked already: Ethernet cable isn't damaged Ethernet port is active I've tried installing drivers onto PC and connecting USB, this works fine, but obviously the idea is to have it on the network. Did a complete reset of printer.

Just completely out of ideas now, so if anyone can get this sorted

share|improve this question
What exactly are you connecting the printer to? (Make and model, if possible. I'm thinking MDI/MDIX mismatch.) – David Schwartz Aug 20 '12 at 9:48
So it's connected to one of its 4 LAN ports? That seems an odd waste of a Gigabit port on the gateway device for a network with 60 computers! – David Schwartz Aug 20 '12 at 9:58
Wired to the server? Why are you connecting a network printer to a server? It should be connected to the network. (Or am I misunderstanding you? What do you mean by a "server stack"?) What exactly is the printer connected to? (Make and model if possible.) – David Schwartz Aug 20 '12 at 10:00
Okay, right, so what does that port connect to? (Make and model, if possible.) I'm thinking MDI/MDIX mismatch. – David Schwartz Aug 20 '12 at 10:03
That's just my jargon... you know it's just those standard ethernet ports that are on the walls of offices, which yes, I suppose I mean network. - and those ports are wired to..... what? – RobM Aug 20 '12 at 12:29
up vote 1 down vote accepted

It seems to me that the green light should light whether or not you actually obtain a valid IP address or whatever. So it sounds like the media is not connected. Could it be that you have a 100mb card plugged into a 10mb switch or vice-versa? Could it be that you need/do not need an ethernet crossover cable?

That's where I'd start looking.

Looking at the user's manual for that printer, there are instructions to software-activate the wired network port. Have you done that?

share|improve this answer
Looking at the user's manual for that printer, there are instructions to software-activate the wired network port. Have you done that?… – Bob Aug 20 '12 at 12:16
I have tried the manual software setup, but the software can never see the printer, as I guess it's not finding the network at all. – Alexander Wigmore Aug 20 '12 at 13:09
It appears to me that you're supposed to connect via USB, then turn on the wired network port then proceed from there... – Bob Aug 20 '12 at 18:08
@Bob: Where do you see any documented method to turn on the wired network port via USB? The directions clearly state to connect the printer to the wired network and then tell the PC software to look on the network for the printer. There's no previous step to configure the printer. (Although setting up by USB is the procedure to configure for wireless printing.) – David Schwartz Aug 21 '12 at 1:35

It's fixed now - turns out the port was dead, even though our IP based phones powered up through it (which is usually the test we do to see if a port is active) it turns out that, that port wasn't fully networked between everything.

Sorry for the hassle - and thanks for the help guys :).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.