Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is the cmd:

pecl install apc

Result:

downloading APC-3.1.9.tgz ...
Starting to download APC-3.1.9.tgz (155,540 bytes)
.................................done: 155,540 bytes
54 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.

ERROR: `phpize' failed

For some reason I cannot install "apc" and "pecl_http".

Also I am using PHP-5.4 and when I compiled it I did:

./configure --enable-fpm --with-mcrypt --with-zlib --enable-mbstring --disable-pdo --with-curl --disable-debug --disable-rpath --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-mbregex --with-mhash --enable-zip --with-pcre-regex --enable-ctype --enable-bcmath --enable-calendar  --enable-exif  --with-gettext --with-openssl --enable-shmop --enable-soap --enable-wddx --with-xmlrpc

I enabled "fpm" is this enough for PHP 5.4 and is it why pecl is not working?

Thanks in advance for any help.

UPDATE:

I did make && make install

Configuration File (php.ini) Path: /usr/local/lib
Loaded Configuration File:         (none)
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)
share|improve this question
add comment

1 Answer 1

You're missing the package php5-dev: http://packages.ubuntu.com/quantal/php5-dev

By activating php-fpm during configuration of PHP 5.4 you enable php-fpm: http://php-fpm.org/

share|improve this answer
    
But do I need to install anything else to make PHP-FPM work? Because when I do a search on my server I can't find the "php.ini" file. –  jnbdz Aug 20 '12 at 23:21
    
I haven't compiled PHP 5.4 on my own, I usually tend to use Dotdeb packages. On my Debian server the configuration files are located at /etc/php5/fpm/ but this most certainly differs if you compile it yourself. Consider doing so yourself, because you need the init scripts! Have you tried find / -name "php.ini" or find / -name "php-fpm.conf"? Or use locate (and do updatedb before). –  Fleshgrinder Aug 20 '12 at 23:28
    
I found it here: /root/src/php-5.4.6/sapi/fpm/php-fpm.conf ...Since I compiled it [PHP] will php5-dev cause problems since I installed it or conflict? –  jnbdz Aug 21 '12 at 0:17
    
The php-fpm.conf is found inside the folder of PHP I downloaded... Is it supposed to be there? –  jnbdz Aug 21 '12 at 0:18
    
Yes, but only for copying to the right place after you did make and make install. Have you done that yet? The procedure is always to run the configure script at first, then make and then make install. Sorry if I just asked you something really dumb, but I want to help you. –  Fleshgrinder Aug 21 '12 at 0:21
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.