Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
CentOS 5.6: How to resolve php53 RPM dependency conflict with php-mcrypt and php-common?

I am trying to use the PHP DOMDocument Class, which requires the installation of php-xml (I'm running CentOS 5.5).

However, upon running yum install php-xml I recieve the error 'php53-common conflicts with php-common', so the install fails. I have no idea where to go with this, so any tips are apprciated. Thanks.

share|improve this question

marked as duplicate by quanta, Michael Hampton, Scott Pack, Magellan, MadHatter Nov 12 '12 at 15:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
yum repolist? –  quanta Aug 21 '12 at 11:03
    
Do you know which version of PHP you're running/have installed? Is it possible that you're trying to install a newer version of php-xml and that's trying to install a newer version of the common files? –  John K Aug 21 '12 at 11:04
    
@quanta - Apologies, I didn't see that one. –  David Gard Aug 21 '12 at 11:18
    
@JohnK - Running PHP 5.3.3, so the issue was indeed that I was trying to install the wrong version of php-xml. yum install php53-xml did the trick. –  David Gard Aug 21 '12 at 11:19
add comment

1 Answer

The issue here is because I am using PHP 5.3.3, and the install requires you to specify that (I thought it picked up your version and installed the relevent module, but I' obviously wrong).

To fix this problem, yum install php53-xml did the trick.

Don't forget to restart service httpd after the install.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.