Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to reach Centos based VPS in OpenVZ.

User prompt goes well, but after I type username, press Enter no password prompt occurs and server drops connection by timeout in a few seconds.

Tried different ssh clients (Windows based).

And NO log records in secure.log! Even no connection initialization records at all!

share|improve this question
    
We need more info. Can you connect with ssh -v and provide the output? –  Patrick Aug 21 '12 at 12:22

1 Answer 1

up vote 3 down vote accepted

Use "ssh -v" to debug the connection. Add more "v"'s for more verbose output. If you are able to install strace on the server you could try to strace the sshd process side with "strace -p PID" command to see what exactly happens.

share|improve this answer
    
Should -v be added on client side? –  webbandit Aug 21 '12 at 12:23
    
yes, ssh -v user@host or ssh -vv user@host etc –  Goez Aug 21 '12 at 12:26
    
You know, the trick is in the fact that my server works well for now. I can connect and no such errors occur. I've read about GSSAPI config options in sshd_config file and these options could affect ssh connection. What do you think about that? –  webbandit Aug 21 '12 at 12:36
    
We cannot judge without any log or ssh -v. Typical and default configuration should never produce any errors like the one you had. Did you change anything in sshd config ? (please also check your local .ssh config as weel) –  wojciechz Aug 21 '12 at 12:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.