Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I intalled opendkim with sendmanil (on Ubuntu) without any problem, and followed the same procedure for installing on another server (Debian with postfix), but it does not work. Strangely, there is no error in the log files too. I figured the problem out by netstat -antup | grep 12345 after restart of opendkim resulting in

tcp    0   0 127.0.0.1:12345   0.0.0.0:*         LISTEN    2678/opendkim

After sending an email, this will be changed to

tcp    0   0 127.0.0.1:12345   0.0.0.0:*         LISTEN    2678/opendkim
tcp    0   0 localhost:59233   localhost:12345   TIME_WAIT

or

tcp    0   0 localhost:59233   localhost:12345   TIME_WAIT

The only resource I found was this stating that this is due to blocking the tcp connection by firewall. However, I have no firewall on this fresh installation of Debian.

  1. Why mail tasks lead to TIME_WAIT? Is it normal?
  2. Why openDKIM stop listening on the port specified in the config?

UPDATE: There is no usual configuration. Relevant SOCKET in /etc/default/opendkim was uncommented, and added these lines to postfix's main.cf:

milter_default_action = accept
milter_protocol = 6
smtpd_milters = inet:localhost:12345
non_smtpd_milters = inet:localhost:12345

The log report (in mail.log) is as

Aug 21 21:37:07 forpicture postfix/pickup[32519]: A349B54203B0: uid=33 from=<admin@forpicture.com>
Aug 21 21:37:07 forpicture postfix/cleanup[32522]: A349B54203B0: message-id=<20120821173707.A349B54203B0@forpicture.us>
Aug 21 21:37:07 forpicture postfix/qmgr[32560]: A349B54203B0: from=<admin@forpicture.com>, size=489, nrcpt=1 (queue active)
Aug 21 21:37:08 forpicture postfix/smtp[32561]: A349B54203B0: to=<for_picture@gmail.com>, relay=gmail-smtp-in.l.google.com[173.194.77.26]:25, delay=0.37, delays=0.09/0.01/0.06/0.2, dsn=2.0.0, status=sent (250 2.0.0 OK 1345570628 bd6si1892134obb.60)
Aug 21 21:37:08 forpicture postfix/qmgr[32560]: A349B54203B0: removed

and there is no log in mail.warn or mail.err.

The opendkim.conf is (only uncommented lines):

UMask           002
InternalHosts           refile:/etc/opendkim/InternalHosts
KeyTable                refile:/etc/opendkim/KeyTable
SigningTable            refile:/etc/opendkim/SigningTable
share|improve this question
1  
Can you update your question with the relevant bits of the postfix configuration? –  cjc Aug 21 '12 at 13:34
1  
What does "not work" mean? Please show us a snippet of /var/log/maillog when testing? –  quanta Aug 21 '12 at 14:14
    
@quanta OpenDKIM does not sign outgoing emails. –  All Aug 21 '12 at 17:43
    
This is OpenDKIM as a standard Debian package? Can you post /etc/opendkim.conf? –  cjc Aug 21 '12 at 17:49
    
@cjc Yes, I installed with apt-get. I doubt if the problem connected with openDKIM, it should be related to postfix. I have the same configuration on another server (Ubuntu running sendmail), and everything is OK. I checked and compared openDKIM configurations. –  All Aug 21 '12 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.