Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have designed a website - say I have bought a SSL cert and then enabled it. So if I type it works. I also went to the Web host manager's .Htaccess folder and set the redirects i.e. the following: If then it should go to the above https site (I am only allowed to have 2 hyperlinks as a new user) and all the variations.

However, this redirect is not working and when I press it is still not showing the 'lock' in IE and in Chrome it says 'Your connection is not encrypted'. Any suggestions or ideas how I can fix this?

Many thanks, Sandeep

share|improve this question

migrated from Aug 21 '12 at 19:23

This question came from our site for information security professionals.

What webserver software are you using? – Jeff Ferland Aug 21 '12 at 17:49
The problem is related to the redirect then, not to SSL. – b0fh Aug 21 '12 at 22:25

From what you've said it would seem that your web server software is listening on port 80 (default for unencrypted web traffic) and 443 (default for SSL encrypted web traffic) and serving the content on both, which is a pretty common configuration.

The details to fix it would depend on the specific software that you're using but in general there's two options you could go for.

1) close port 80 and only run on 443 with SSL enabled. That way anyone going to your site would need to remember to use https:// at the start of the request or it won't work. So people going to would just get an error.

That's not massively user friendly so the other option would be

2) automatically redirect any requests for the unencrypted site on port 80 to the encrypted site on port 443. How you do that is down to the specific software that you're using, but for Apache as an example one way to do it would be this

share|improve this answer
+1 Great suggestion – ZnArK Aug 22 '12 at 13:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.