Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my network, I have a main Cisco 2950 that connects to my outside bandwidth, then individual Cisco 2950s in each cabinet that connect back to the main one.

I recently had someone in one cabinet start consuming 100% of the bandwidth in my network. As a quick fix, I set the speed on the main switch to be 10Mbps for the port that connects to the switch in the cabinet.

After doing that however, the port now shows down (notconnect). I've tried setting the speed back to 100, and shutting down/starting the port again, but it never reconnects. Any recommendations on getting this port back up, short of rebooting the switch in the end cabinet (I can't connect to the switch)

Here is what I did:

config t
int FastEthernet1/0/47
speed 100
duplex full
end

Even after resetting the speed, I'm getting:

sh int FastEthernet1/0/47
FastEthernet1/0/47 is down, line protocol is down (notconnect) 
  Hardware is Fast Ethernet, address is 0016.4797.4633 (bia 0016.4797.4633)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, 
     reliability 255/255, txload 1/255, rxload 73/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX

Before changing the speed:

sh int FastEthernet1/0/47
FastEthernet1/0/47 is up, line protocol is up (connected) 
  Hardware is Fast Ethernet, address is 0016.4797.4633 (bia 0016.4797.4633)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 209/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
share|improve this question
    
Try setting the port to auto-negotiate. And, well, you do now know why what you did isn't a good idea to deal with a bandwidth hog, right? –  HopelessN00b Aug 22 '12 at 5:53
    
I've tried "speed auto", but it not work. What eventually did was "duplex auto". The "speed 10" works pretty well when a server is connected directly to the switch, but switch-to-switch, obviously not. Thanks –  John P Aug 22 '12 at 6:02
    
1. So the user is consuming 100% of all the bandwidth of all the links/ports? Wow, that is pretty amazing. 2. How is setting the port to 10Mbps going to help? If they're consuming 100% of a 100Mbps or 1Gbps link then certainly they're going to consume 100% of a 10Mbps link. My advice: find a different solution to the problem. –  joeqwerty Aug 22 '12 at 15:00

2 Answers 2

up vote 2 down vote accepted

Per the comments, the solution was set the port to autonegotiate, rather than manually defining speed and duplex settings.

And this kind of problem (as well as other potential issues) is why it's a bad idea to limit bandwidth by forcing a switch-to-switch port to a lower speed and/or duplex setting manually.

share|improve this answer

As already mentioned, this is not the best way to take care of this problem. However, for some specifics as to why things worked the way they did for you, it's worth knowing that the main problem came from having one side set manually, and the other side set statically.

As soon as you manually set the duplex on one side, you needed to also set the duplex on the other side as well. Auto-negotiation wouldn't work in this case if one side has a manually set duplex. This is why setting it back to auto-negotiate fixed the problem (although not the bandwidth hog problem).

In addition, messing with the duplex on only one switch could have caused the port to go into err-disable state requiring manual console into the other switch and resetting the port.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.