Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Earlier this year we moved from an EMC Celera NAS to an IBM XIV. We use mapped drives to map to an area a few folders down from the root. Following the change of NAS users reported the inability to open links pointing to the mapped drive in Outlook, at the time I had 2010 and could not open or create working links to the new mapped drive even though it should be set up the same as the previous fileshare.

I tried a test laptop with 2003 and I could open the links, running Process Monitor showed no problems opening the files with 2003 but with 2010 access was clearly denied to the top level of the share , it then attempted the folder below (both higher than where the drive maps to) but reported that it couldn't find it, through further investigating we established that the issue affected 2003 afterall, and 2007. The only way to send/open these links successfully was by sending in rich Text with Word set as default viewer and editor (how the test laptop was already setup). I.e. HTML emails with links can't be opened.

It seemed that this was because the working links referenced the mapped drive while the unworking links referenced the full UNC path (hence why Process Monitor showed it trying to get access to the root of the share) but then we realised that certain people could open links with UNC references and it turned out that all these people had higher permissions, we removed these permissions from the working users and they lost their ability to open these links. So that seemed pretty conclusive to me that there is a permissions issue with the new NAS however our server team have said that everything is setup correctly and identically to the old NAS and that this is simply an issue with Outlook, but to reiterate this affects all versions of Office we have in use - 2003,2007 and 2010 and the issue was first noticed a few days after we moved to the new NAS. So, can anyone offer any assistance as to why this issue is occuring? Surely 3 different versions of Outlook didn't develop a fault coincidentally at the same time as we switched NAS?

We also tried basic stuff like creating new user profiles etc and using other machines and tried tons of suggestions on forums but changing permission levels was the only thing that made any real difference. Also, if you unmap the drive and send the link then it will work (displays as the mapped drive path) presumably because Outlook can't convert it to the UNC path as it can't find the drive mapping and so it stays as the mapped drive path. so when the user gets an email with the link it looks for the drive mapping and works.

Hope all that makes sense, first time here, go easy on me etc.

share|improve this question
3  
The XIV isn't a NAS, it's a SAN. That means that they have a file server or NAS head getting storage from XIV and making it available over CIFS or NFS. Secondly, we can't help you unless you have administrator access to the systems causing a problem. My best advice is to prove there's a problem to your sysadmins, and have them come and ask if they can't figure it out. –  Basil Aug 22 '12 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.