Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a website I'm building, I have a png file that appears on the website many times. Everything works fine on my computer, but when I put it on Apache, everything loads but the image. I've deleted every file on the server and reuploaded everything, and it still doesn't work. I've confirmed it works locally before and after reuploading it. What could be going wrong?

share|improve this question
Have you looked into the permissions on the image itself? – Univ426 Aug 22 '12 at 16:40
@JohnK it's 777 rwxrwxrwx on my machine, but for some reason every file on the server is rw-r--r--, except this one, which became rw-------. Weird, but it's fixed. – tkbx Aug 22 '12 at 16:42
That is strange. What method do you use to copy the files over? That'd be my top guess for the culprit. Glad to know its working! – Univ426 Aug 22 '12 at 16:49
If the issue is fixed, please put the "fix" as an answer and accept it, or just delete this question. Thanks. – Mark Stosberg Aug 22 '12 at 17:03
@Mark, we don't delete question from this site when they're solved. We leave them so others with the same problem can find them. Nor do we edit the title. Please take a few moments to familiarise yourself with the site before making any more such comments. – John Gardeniers Aug 24 '12 at 0:42
up vote 2 down vote accepted

I would recommend double checking the permissions - seems like that would be the most likely culprit.

share|improve this answer

There could be a problem with the permissions. Check that the user running the server process has permission to view the file in question.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.