Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have some encoding software running on Windows Server 2008 R2 that when a user is logged in locally he is able to operate the software and everything is fine. When he remote desktops to the computer the software is saying we've reached the maximum number of encoders available for this license.

Can anyone think of a way to have a remote desktop user treated as the local user?


More information:

When the local admin or another domain user logs in it says the software is not registered. I believe the licensing is for one user so this makes sense.

The server is part of our domain but not a domain controller. And the software in question is Digital Rapids Stream 3.7.

The software was working via remote desktop on a different domain on a windows 2003 server. We had to do a hardware and domain migration.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It sounds like your encoding software has decided to only run on physical sessions or only session 1 or something, to avoid licensing abuse or avoid being used on a Remote Desktop Server / Terminal Server.

There were changes that were made in this arena between 2003 and 2008, which is why it worked for you on 2003 but now does not. Read this:

http://support.microsoft.com/kb/947723

From that same article, you might give this setting a try:

The Restrict Terminal Services users to a single remote session Group Policy setting determines whether you can connect to your existing physical console session. This setting is available in the Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Connections node of the Local Group Policy Editor. You can also configure this setting in Terminal Services Configuration. The Restrict each user to a single session setting appears in Edit settings in the General section.

share|improve this answer
    
Haha, You beat me my thirty seconds. Oh well. –  notandy Aug 22 '12 at 19:31
    
Yeah I hate it when that happens! –  Ryan Ries Aug 22 '12 at 19:55
    
@RyanRies /admin isn't working from the osx client and /console isn't doing anything :( Terminal services isn't running on this but Remote Desktop Services are so the gpo is Local Computer Policy \ Computer Configuration \ Windows Components \ Remote Desktop Services \ Remote Desktop Session Host \ Connections \ Restrict Remote Desktop Services users to a single... but it also didn't work. Thanks for the ms kb article though! –  Tawm Aug 22 '12 at 22:53
    
/console doesn't exist in Windows 2008 and above any more. /admin does nothing unless the server is a Terminal Server or RDS server. If the GPO setting didn't work, then you might need to get technical support from the encoding software vendor. Sorry I didn't have a silver bullet for you. :( –  Ryan Ries Aug 23 '12 at 1:02
    
Additional hint: The software may be checking to ensure that the session logon type is 2. View your session logon type with Powershell like this: $(Get-WMIObject win32_Session).LogonType –  Ryan Ries Aug 23 '12 at 1:07

I think the best bet is to connect to the server using the /admin switch. http://support.microsoft.com/kb/947723

Start > Run

mstsc /admin

and then remote to the server. You should then be connecting to the console session, which may resolve your issue.

share|improve this answer
    
So the user is using the OSX client and when he connects with /CONSOLE he gets the error message of the users. /ADMIN or /admin with the hostname or ip says server not found. –  Tawm Aug 22 '12 at 21:31
    
I don't think the OSX client supports the /console (or /admin) flag. For Windows, you have to do it from the command prompt when you launch mstsc.exe –  MikeAWood Aug 30 '12 at 21:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.