Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my (new) mac I can use spork and redis seems to be already running.

However on my Ubuntu system (11.10) I get

Connection refused - 
Unable to connect to Redis on localhost:6379 (Errno::ECONNREFUSED)

I can get around this with redis-server which start redis as a foreground process in that window.

How can I have redis-server always be running on my Ubuntu ? i.e. through reboots

I thought about putting redis-server in my .bashrc but I don't want a new redis server started with each new terminal window. Could it go in my .bash_login ?

share|improve this question

migrated from stackoverflow.com Aug 23 '12 at 6:08

This question came from our site for professional and enthusiast programmers.

    
Have you tried running install_server.sh?github.com/antirez/redis/blob/2.6/utils/install_server.sh –  Mladen Jablanović Aug 20 '12 at 13:00

1 Answer 1

up vote 3 down vote accepted

The trick is to put an init script in your /etc/init.d/ and then use the update-rc.d command to enable/disable it. I use a modified version of this init script. Also take a look at this post. Hope it points you to the right direction.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.