Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

There are a network and a different network on a second location with on both networks are a router with 192.168.x.1 who route the traffic.

Now i install a new Router with and connect with ipsec to, i can route from one net to another, but only if i add as gateway for the network. Now i add a route from over to to and it works i can ping hosts from 192.168.0.x to the 192.168.50.x but not in the other direction. So if i test the route from 192.168.50.x over to over to 192.168.0.x then i can't ping the Host. What can i do that it works?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Update After discussing this in chat, we determined the problem was handling the static routes between and There aren't any hosts connected to, but if there were, there would be no way to route traffic to and get that traffic to both groups of hosts. Even with no hosts, getting to the router itself (for admin purposes) at puts you in a static loop with

Th solution is to subnet out the two routers, and then statically route the two subnets properly, thereby avoiding any conflicts in routing.

share|improve this answer
Hey John, thanks for your answer. Yes we use static route and i don't set a route from to because i don't know what route i should set. If i set route add net mask i can access my – kockiren Aug 23 '12 at 14:31
Well, you shouldn't need a route from to, as they're on the same network, but you should have one from to the network. It sounds like the only connection there is from to - is there a static route set at the router for the network? – Univ426 Aug 23 '12 at 14:37
There are no routes because it is set over the ipsec-tunnel. I don't need any routes in this tunnel. I think. If i ping devices who set as gateway then it works. – kockiren Aug 23 '12 at 14:53
Ahh ok, in that case, try setting a default route on to I think that would look like "ip route" – Univ426 Aug 23 '12 at 14:56
Okay but i cant set a default route because the default traffic should go over the WAN Gateway of – kockiren Aug 23 '12 at 14:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.