Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hey all and thanks in advance, this is an easy one for alot of you on here. I have a 2 server setup a web server and database backend. Well I am having issues optimizing my apache settings and don't have much experience in doing so. Specs here:

Web Server CPU= Dual Quad Core Intel(R) Xeon(R) CPU E5606 @ 2.13GHz Memory= 16GB OS=CentOS 5.6 Apache= 2.2.17

So far the server will reach around a max of 400-500 concurrent connections, but generally stays around 150 or so. Below is my httpd.conf settings.

ServerRoot "/usr/local/apache2"
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100  
KeepAliveTimeout 15  
serverLimit 1000  

<IfModule prefork.c>  
    StartServers        10   
    MinSpareServers     10  
    MaxSpareServers     10  
    MaxClients         1000  
    MaxRequestsPerChild  0  
</IfModule>  

<IfModule worker.c>  
    StartServers        2  
    MaxClients         533  
    MinSpareThreads     50  
    MaxSpareThreads    100   
    ThreadsPerChild     30  
    MaxRequestsPerChild  0  
</IfModule>  

<IfModule perchild.c>  
    NumServers           3  
    StartThreads         3  
    MinSpareThreads      5  
    MaxSpareThreads     10  
    MaxThreadsPerChild  20  
    MaxRequestsPerChild  0  
</IfModule>  

<IfModule mpm_netware.c>  
    ThreadStackSize      65536  
    StartThreads           250  
    MinSpareThreads         25  
    MaxSpareThreads        250  
    MaxThreads            1000  
    MaxRequestsPerChild      0  
    MaxMemFree             100  
</IfModule>  
share|improve this question
    
Can you clarify what the problem is that you're trying to resolve? Are you looking to increase connection concurrency? Are your users running into errors when the system is under high load? –  Shane Madden Aug 23 '12 at 17:24
    
MaxClients 1000 - this setting is dangerous, 1000 Apache workers will effectively utilize virtually any amount of server's RAM. Your setting should be more realistic. –  Alex Aug 23 '12 at 17:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.