Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been granted admin access to an internal IIS server on which I need to set up a web site.

Before doing anything technical I wanted to ensure that I could access the server, but when attempting to access a simple page (that does not refer to Sharepoint) at

http://localhost/index.html 

when logged onto the server directly, I am getting

Parser Error 
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. 

Parser Error Message: Could not load file or assembly 'Microsoft.SharePoint' or one of its dependencies. The system cannot find the file specified.

Source Error: 
Line 1:  <%@ Assembly Name="Microsoft.SharePoint"%><%@ Application Language="C#" Inherits="Microsoft.SharePoint.ApplicationRuntime.SPHttpApplication" %>

Source File: /global.asax    Line: 1 
Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.SharePoint' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value
[HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value 
[HKLM\Software\Microsoft\Fusion!EnableLog].
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.5456; ASP.NET   
Version:2.0.50727.5456 

To be quite honest I know zip about Sharepoint, so why am I getting a sharepoint error on a basic "hello world" html page?

Cheers :)

Update: I've since supposedly uninstalled Sharepoint, but am still getting this error. Any ideas welcome!

share|improve this question
    
Need moar details. Like the full error message, which should include a bunch of stuff after The system cannot find the file specified. But is sure sounds like you've set IIS up to serve a SharePoint site, and then not installed SharePoint. –  HopelessN00b Aug 24 '12 at 16:03
    
I've now uninstalled Sharepoint from the server completely (lucky to be able to do this tbh) and still getting the same error. Ye gods.. –  Fetchez la vache Aug 29 '12 at 15:56
    
You should edit that into your question to update it (that's encouraged here), or wait and I'll do it when I get back from lunch, assuming the latest fire gets put out by the db maintenance I kicked off. –  HopelessN00b Aug 29 '12 at 16:47
add comment

1 Answer 1

up vote 0 down vote accepted

OK, Uninstalling Sharepoint (I'm lucky to be able to do that on the server I'm on) didn't solve it, and I'm still getting the same error. The server install can therefore be assumed to be "in a right old state"...

However, after creating a new site on a new port number, rather than in the default web site seems to get round the problem for now.

As to why the default site is acting in the way it is it's anybody's guess. I'll update the original post with the full error, and not mark this post as the answer as it's a workaround at best, rather than a fix, and if anyone knows how to fix it then it'll save me a re-install. Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.