Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2008 server on Amazon EC2. I have installed Jboss 7 server on pot 8080 (IIS is running on port 80). When I execute http://localhost:8080 from within the server on a browser it works fine. But when I access same from outside http://IPaddress:8080 the request times out. Please note http://IPaddress works fine and points to IIS app.

I looked around in this forum and found a couple of useful commands

netstat -a -n correctly displays that port 8080 is listening

Then I added 4 rules in Windows firewall, 2 for inbound traffic on port 8080 for UDP and TCP and 2 for outbound traffic on port 8080

Now when I do netsh firewall show state, it shows port 8080 for both UDP and TCP under heading "ports currently open on all network interface"

Is there anything I am missing? How can I access port 8080 from Internet for this server

share|improve this question
    
Is your server connected directly to the internet or do you need to set up a NAT rule for a router / gateway device? –  DKNUCKLES Aug 24 '12 at 13:19
    
@DKNUCKLES no idea about that. Actually I am using an existing windows server. Could you please let me know how to check if NAT rules are set on a machine? –  Kamal Aug 24 '12 at 13:31
    
The NAT rules would be set on the router or firewall that sits on the perimeter of the network. I have never worked with EC2 before so I'm not sure if that's the case, but if you have a firewall in place you'll need to set up a rule to allow port 8080 to forward to your server at port 8080. Also make sure that you've set the firewall rules up for Public in the Windows advanced Firewall settings, and not domain or private. –  DKNUCKLES Aug 24 '12 at 14:10

1 Answer 1

My bad! The issue was actually with Jboss setup. Jboss does not run by default in broadcast mode.

Jboss 7 comes with a setup file standalone.xml which has a tag <interface name="public">, this is by default to set to 127.0.0.1. I needed to change it to <any-address>

For details

http://stackoverflow.com/questions/6853409/binding-jboss-as7-to-all-interfaces

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.