Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am new to apache and SSL and configuration, i got verysign certificte to secure my site. i have public, private and ca_intermediate cert files. i have configured ssl.conf as below

 VirtualHost _default_:443>
 DocumentRoot /var/www/mydomain.com/web/
 ServerName mydomain.com:443
 ServerAlias www.mydomain.com 
 # Use separate log files for the SSL virtual host; note that LogLevel
# is not inherited from httpd.conf.
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on

problem is that when i access www.mydoamin.com with "HTTP" it works fine, but when i access using "HTTPS" it just opens apache default page. but with green "HTTPS" means my certificates are installed correctly. How can i get rid of this situtaion. Thanks

EDIT Output of apachectl -S

-bash-3.2# apachectl -S
[Mon Aug 27 10:20:19 2012] [warn] NameVirtualHost 82.56.29.189:80 has no VirtualHosts
[Mon Aug 27 10:20:19 2012] [warn] NameVirtualHost 82.56.29.189:443 has no VirtualHosts
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
_default_:8081         localhost.localdomain (/etc/httpd/conf/sites-enabled/000-apps.vhost:10)
*:8080                 is a NameVirtualHost
         default server localhost.localdomain (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:10)
         port 8080 namevhost localhost.localdomain (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:10)
*:443                  is a NameVirtualHost
         default server mydomain.com (/etc/httpd/conf.d/ssl.conf:81)
         port 443 namevhost mydomain.com (/etc/httpd/conf.d/ssl.conf:81)
*:80                   is a NameVirtualHost
         default server app.mydomain.com (/etc/httpd/conf/sites-enabled/100-app.mydomain.com.vhost:7)
         port 80 namevhost app.mydomain.com (/etc/httpd/conf/sites-enabled/100-app.mydomain.com.vhost:7)
         port 80 namevhost mydomain.com (/etc/httpd/conf/sites-enabled/100-mydomain.com.vhost:7)
Syntax OK
share|improve this question
    
What's the output from apachectl -S? –  Shane Madden Aug 25 '12 at 21:47
    
apachectl -S output is added in the question. –  Asghar Aug 27 '12 at 9:23

1 Answer 1

up vote 0 down vote accepted

Adding the directory tag , where my web files are located. solved the problem. its working fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.