Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

System: OS: Debian 6.0 64-bit with KVM installed from packages
KVM is managed with Cloudmin 6.4.kvm

I have a /29 subnet from my host. The bridge is setup properly for each VM to have its own IP, assigned through a DHCP server running on the host. I followed this guide from my host: http://wiki.hetzner.de/index.php/KVM_mit_Nutzung_aller_IPs_aus_Subnetz (You'll have to run it through GTranslate, it's a German host, so German guide)
Host IP (not my real IP): 1.2.3.4
My subnet is 5.6.7.8/29, which means I have the following IP's available to my VM's:
5.6.7.8
5.6.7.9
5.6.7.10
...
5.6.7.15

As mentioned, the routing is setup and the 4 VM's I do have setup all have an IP and can communicate with the outside world and each other. That's not the problem I'm having. When I attempt to add another IP to a VM, the IP is not able to ping from the outside world.

For the record, my ultimate goal is to be able to run a DNS server and have it registered, so that I can point all my domains to it and control DNS from a virtualmin installation installed on one of the VM's (and therefore make it easier to run my websites instead of having to go into my registar's DNS console, making a subdomain, then making an apache virtual server manually, yadda yadda).

So, when I create a VM, it gets the next available IP, which, in this case, is 5.6.7.11. I want to also be able to give this VM 5.6.7.12 or even 5.6.7.13, or any other available IP. When I do, however, the IP cannot be ping'd from the outside world.

Steps I take:
1. Create the VM as usual in Cloudmin.
2. Install the OS and get the first IP setup on the VM
3. Navigate to 'System Configuration' -> 'Network Interfaces' in Cloudmin and add another ethN device with the desired MAC Address and bridge device as per my hoster's guide above.
4. Add the new device to the VM and then reboot the VM, but when it comes back up, the ethN I added (eth1) claims it's not present on the VM, so I can't do something like
ifconfig eth1 up
or I'll get the error message "No such device".

I think it's because Cloudmin assigns an IP to the machine and then adds an entry to some sort of routing on the host. I can't find any documentation on this, though. Does anyone have any ideas on how I can accomplish this?

EDITED: Alternatively, is there a better, open source GUI that I can use to administrate KVM that will allow me to do this easier that you would recommend?

share|improve this question

2 Answers 2

First, make sure you have set up bridging properly so that your virtual machines can communicate with the network.

Second, create an IP Pool containing your /29 network and the gateway address within that /29. Setting the gateway address correctly is probably the part you missed. Hetzner will let you know which address in the /29 is the gateway.

Third, assign IPs to virtual machines and enjoy.

share|improve this answer
    
As mentioned above, I've already done that. When you build a VM through Cloudmin, it assigns ONE IP to the machine automatically (or if you so choose, you can assign an IP manually, as long as it's one in your pool and it's available). My issue stems from when I try to assign the second IP in Cloudmin through 'System Configuration' -> 'Network Interfaces' the VM doesn't see it. I can't activate it. If I $ ifconfig eth1 up I get an error "No such device". I looked into Cloudmin's documentation and it states I can add a virtual interface (ethN:n) but I don't see that option. –  Jguy Aug 24 '12 at 21:34
    
Are you sure there's an eth1 device in your guest? Usually it's eth0 or em1 or something like that. –  Michael Hampton Aug 24 '12 at 21:38
    
I just setup a new guest, and gave it devices eth0 and eth1 through Cloudmin (IP's 5.6.7.10 and 5.6.7.12). I started the OS installation (Ubuntu Server 12.04 x64) and for the step of setting up the networking interfaces, it detects that it has multiple interfaces: eth0: Ethernet rename3: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ In the Cloudmin interface, I see that eth0 is Not active and eth1 is active. I can configure the network with eth0 and use that device to connect to the internet. I'm running through the rest of the installation and will add the other interfaces soon. –  Jguy Aug 24 '12 at 21:59
    
When I setup an eth0 AND an eth1 through the Cloudmin interface and reboot the machines after the initial OS install, both of the interfaces are not detected by the VM and therefore they cannot reach the outside world and nothing can reach them. I'm trying a few things, though. –  Jguy Aug 26 '12 at 13:33
up vote 0 down vote accepted

Solved by this post (which I had also posted) KVM with one host IP and a different subnet for machines

Setting it up without the DHCP allows me to use more than one IP per guest very easily.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.