Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up my own bind server for swic.me, however i cant make it respond for that domain at all! Asking for other domains like google.com works so the basic config should be ok.

Here is my named.conf.local

zone "swic.me" {
        type master;
        file "/var/lib/bind/swic.me.hosts";
        };

and my /var/lib/bind/swic.me.hosts

$ttl 38400
swic.me.    IN  SOA ns1.swic.me m.maciekish.com (
            1345843666
            10800
            3600
            604800
            38400 )
swic.me.    IN  NS  ns1
swic.me.    IN  NS  ns2
ns1 IN  AAAA    2001:470:28:81:34:110
ns1 IN  AAAA    2001:470:28:81:34:110

swic.me.    IN  AAAA    2001:470:28:81:34:110
swic.me.    IN  A   127.0.0.1

Asking for the NS returns the following

; <<>> DiG 9.8.1-P1 <<>> swic.me @localhost
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 13655
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;swic.me.                       IN      NS

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Aug 25 00:09:42 2012
;; MSG SIZE  rcvd: 25

I think the config is OK as services bind9 restart throws no error and says [OK]

Note: I am aware of the A record pointing to localhost, this domain will be used solely for ipv6 testing and this is the intended configuration!

share|improve this question

2 Answers 2

You're missing DNS glue records for your domain.

Since you're using GoDaddy you can set these up in the GoDaddy control panel. After clicking your domain and "Launch", look in the lower left corner for this and add the records for ns1 and ns2 there.

enter image description here

You should put the same address records in your bind zone file as well.

share|improve this answer

Here is the problem:

ns1 IN  AAAA    2001:470:28:81:34:110
ns1 IN  AAAA    2001:470:28:81:34:110

should be

ns1 IN  AAAA    2001:470:28:81:34:110
ns2 IN  AAAA    2001:470:28:81:34:110
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.