Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've run chmod 777 on /home/cache/, however the apache user is still unable to write to it. My php script is writing to this directory but got a permission denied error and don't know why.

ls -ld cache shows:

drwxrwxrwx. 2 root root 69632 Aug 24 17:04 cache/

ls -ld /home shows:

drwxr-xr-x. 19 root root 4096 Aug 24 18:30 /home

share|improve this question
1  
Also post the error log here? –  quanta Aug 25 '12 at 9:21
    
And what is the exact error message that the php function returns? –  Iain Aug 25 '12 at 9:48

1 Answer 1

Change the owner permission of the /home/cache/ to "apache user" by running the command:

chown apache /home/cache/

After that ensure selinux is turned off in your system. You can run setenforce 0 to turn selinux off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.