Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

CentOS 5.x 64bit w/ Plesk server : yum update wants to update kernel etc, is this ok? this is what 'yum update' outputs :

--> Running transaction check
---> Package kernel.x86_64 0:2.6.18-308.13.1.el5 set to be installed
---> Package kernel-headers.x86_64 0:2.6.18-308.13.1.el5 set to be updated
---> Package php.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-cli.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-common.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-devel.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-gd.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-imap.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-mbstring.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-pdo.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package php-xml.x86_64 0:5.3.16-9.el5.art set to be updated
---> Package sudo.x86_64 0:1.7.2p1-14.el5_8.3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================

Installing:
 kernel                                                      x86_64                                              2.6.18-308.13.1.el5                                              updates                                               21 M
Updating:
 kernel-headers                                              x86_64                                              2.6.18-308.13.1.el5                                              updates                                              1.4 M
 php                                                         x86_64                                              5.3.16-9.el5.art                                                 atomic                                               2.8 M
 php-cli                                                     x86_64                                              5.3.16-9.el5.art                                                 atomic                                               2.6 M
 php-common                                                  x86_64                                              5.3.16-9.el5.art                                                 atomic                                               1.0 M
 php-devel                                                   x86_64                                              5.3.16-9.el5.art                                                 atomic                                               1.3 M
 php-gd                                                      x86_64                                              5.3.16-9.el5.art                                                 atomic                                               209 k
 php-imap                                                    x86_64                                              5.3.16-9.el5.art                                                 atomic                                                88 k
 php-mbstring                                                x86_64                                              5.3.16-9.el5.art                                                 atomic                                               2.3 M
 php-mysql                                                   x86_64                                              5.3.16-9.el5.art                                                 atomic                                                95 k
 php-pdo                                                     x86_64                                              5.3.16-9.el5.art                                                 atomic                                               120 k
 php-xml                                                     x86_64                                              5.3.16-9.el5.art                                                 atomic                                               226 k
 sudo                                                        x86_64                                              1.7.2p1-14.el5_8.3                                               updates                                              359 k

    Transaction Summary
=============================================================================================================================================================================================================================================
Install       1 Package(s)
Upgrade      12 Package(s)

Total download size: 34 M
Is this ok [y/N]:

Should I go ahead and update or not? Thanks

share|improve this question

2 Answers 2

up vote 0 down vote accepted

yes you should.. the kernel needs to be updated mainly for security fixes. You'd have to reboot to run that version though.

share|improve this answer
    
Ok thanks Mike I went ahead nad did the upgrade, everything seems to be fine. –  Jizbo Jonez Aug 25 '12 at 11:07

Yes, that's fine. Have a careful look, it says installing new kernel and that's way it has to be, because the old one is kept in case of problems.

I've never used plesk and not sure if a kernel upgrade could cause trouble, but usually Red Hat (CentOS...etc) don't change kernel version, the upgrades are just revisions (security, fixes, etc) over the same kernel that was shipped with the distro when released.

In case of problems you should be able to easily boot into your previous kernel from grub.

share|improve this answer
    
Thanks for the additional info tripledes –  Jizbo Jonez Aug 25 '12 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.