Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am pretty sure this there is an easy solution to this problem but I just can't seem to find the answer.

Here is my issue. I have installed vsftpd on my ubuntu 10.04. I created a group and a user for this and set up the password. I can now ftp to my server and read all the files I want; however, I cannot write/edit/delete any folders. I have made sure I have changed the group/user of /var/www to the newly created group and given 777 permissions recursively. I still can't edit/upload/delete anything at all.

Can anyone help with this?

share|improve this question

migrated from stackoverflow.com Aug 25 '12 at 10:52

This question came from our site for professional and enthusiast programmers.

    
look at your vsftpd.conf - out of the box all write commands are disabled – Eugen Rieck Jan 24 '12 at 17:03

check that write_enable is erm enabled write_enable=YES

The default is NO and it affects the following commands STOR, DELE, RNFR, RNTO, MKD, RMD, APPE and SITE which can change the filesystem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.