Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure a DB2 DSN on a Windows 7 machine, to a remote DB2 server. I've installed the driver, per the instructions here. That appeared to work fine; I've already cataloged the node and database using the command line processor (database is cataloged as "DB1"), and then when I go to the ODBC configuration in the Windows Control panel, the database I've catalogued is available when I create a DSN using the DB2 driver.

But, when I test the connection, I get:

SQL1013N The database alias name or database name " " could not be found. SQLSTATE=42705

I then realized I'd have to configure the CLI parameters - I've added and applied the Database, Protocol, Hostname and Port within the CLI/ODBC settings in the ODBC configuration dialog window. However, I still get the same message.

I've tried rebooting the client machine, but that doesn't change things. IBM refers to a db2cli.ini file that should be in the install directory, but there isn't a file there. Does that mean the installation didn't work correctly, or by default is there no db2cli.ini file until you create one?

I tried on a second client machine, and this time I got:

SQL1531N The database alias "DB1" could not be found in the db2dsdriver.cfg configuration file.

This is even stranger, as I can't find the db2dsdriver.cfg file. (It's not in the directory it should be, given this article.) and further, I can't run db2dsdcfgfill to create the file, because (again) I can't find a db2cli.ini file to use as the input for db2dsdcfgfill.

Is that normal? I haven't used DB2 for about 6 years but I remember some of IBM's tools being rather hard to configure; am I being extra-specially inept?

share|improve this question

migrated from stackoverflow.com Aug 25 '12 at 11:06

This question came from our site for professional and enthusiast programmers.

    
Probably not useful in solving your problem, but you're not being inept. IBM's tools are so awful and difficult to configure, you think they're the hardest things in the world to use... until you visit their site for documentation and remember that's actually the hardest thing in the world to use. –  HopelessN00b Aug 26 '12 at 8:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.