Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have configured Yum Server on Server 10.0.0.1(Redhat 5.3) All RPMS are here /home/RPMS/Server.

Now on another machine i have Centos 5.3 (10.0.0.30).I want to use yum Server of 10.0.0.1 on 10.0.0.3 as client.

So i did edit yum.conf file on client as

[b]
baseurl=ftp://10.0.0.1/home/RPMS/Server
gpgcheck=0

When i am passing command yum list then it is showing error.

[root@client30 ~]#  yum list
Repository 'b' is missing name in configuration, using id
ftp://10.0.0.1/home/RPMS/Server/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] (113, 'No route to host')
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: b. Please verify its path and try again
[root@client30 ~]#

But if put RPMS on server under /var/ftp/pub/RPMS then ,evrything working fine.

I have already given 777 permission on server.

Kindly help what i can do so that client start using yum server configured on Server with the same file path.Actually size of / is small so i cant put files under /var/ftp/pub.

Kindly help

share|improve this question
    
When i am passing command yum list then it is showing error -> what errors? –  quanta Aug 27 '12 at 3:33
    
The error is [root@client30 ~]# yum list Repository 'b' is missing name in configuration, using id ftp://10.0.0.1/home/RPMS/Server/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] (113, 'No route to host') Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: b. Please verify its path and try again [root@client30 ~]# –  Deepak Narwal Aug 27 '12 at 6:01
add comment

migrated from stackoverflow.com Aug 26 '12 at 22:17

This question came from our site for professional and enthusiast programmers.

1 Answer

Repository 'b' is missing name in configuration

Define a name for your repo, something like this:

[b]
name=Local repo - $basearch
baseurl=ftp://10.0.0.x/home/RPMS/Server
enabled=1
gpgcheck=0

ftp://10.0.0.x/home/RPMS/Server/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] (113, 'No route to host')

It seems caused by a firewall. Can you access this URL via web browser?

share|improve this answer
    
No route to host from something I expected to be on the LAN generally indicated the host is down, rather than firewalled. But it could go either way. –  Michael Hampton Aug 27 '12 at 8:39
    
Yaa u are right.Firewall was enabled sir.BUt i am able to ping.Now i disable firewall and selinux and again i tried then it is showing error –  Deepak Narwal Aug 27 '12 at 8:51
    
Now i disable firewall and selinux and again i tried then it is showing error `[root@client30 ~]# yum list 10.0.0.1/home/RPMS/Server/repodata/repomd.xml: [Errno 4] IOError: [Errno f tp error] 550 Failed to change directory. Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Server. Please verify its path and try again –  Deepak Narwal Aug 27 '12 at 8:57
    
ls -ld /home/RPMS/Server? –  quanta Aug 27 '12 at 9:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.