Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I create a public share on Windows Server 2012 for use within my workgroup/network?

I have managed to create a share within the File and Storage Service, but I'm not sure how I can make the share public so that no authentication is needed when I try to mount the network share from a different computer on my private network.

Or is there an alternative? Should I create a user on the server just to login to the share? (I don't want to give out the administrator password to people on the network).

It's on a workgroup, not a domain. (Should I setup a Domain Controller instead?)

share|improve this question

2 Answers 2

up vote 2 down vote accepted

As Brent states, the easiest, but least secure approach, is to give the Everyone group access.

However, it's probably a better idea to setup a user just for access to that share and give out the credentials to that account. It's more secure, and gives you more options - you can set up different users with different access levels, and if your network is compromised, you have some protection against a malicious user stealing or destroying the information on your share. Or if the credentials end up being distributed, you can change the password, so only the people you want to have access, actually have access.

As to setting up a domain... that's an option too, but depending on the size of your network (how many users and client machines), it might be more trouble than it's worth. Though, aside from very small network setups, it does make life a lot easier, allowing central management of all user accounts, permissions and even cmputers, just for starters.

share|improve this answer
    
The size of the network is just 2-4 pcs, mostly operated by me :) –  s093294 Aug 27 '12 at 15:22
    
@s093294 The single user is not a bad idea. You can also map the network share and save the credentials so that may be the best answer. –  Brent Pabst Aug 27 '12 at 15:28
    
@s093294 Yeah, don't bother setting up a domain. Way more trouble than it's worth at that size. –  HopelessN00b Aug 27 '12 at 16:05

The easiest thing to do would be to simply grant the "Everyone" group read and/or read/write access both at the NTFS and Share levels. Then you simply need to have the IP or NetBIOS name to connect to it.

Although, this is highly insecure and not really best practice. Your best option will always be to setup Active Directory for the best amount of control and ease of management. However, if like you say, this is a private network with all trusted users then you shouldn't have an issue with just using the everyone group.

share|improve this answer
    
I have within the File and Storage Service management set the everyone group to full access. Still i get teh login screen on the second computer. –  s093294 Aug 27 '12 at 15:15
    
Have you set the Everyone group on the Share Permissions AND the NTFS permissions? You must do both. –  Brent Pabst Aug 27 '12 at 15:16
    
I am not sure how to do it on the NTFS permissions. (also , i am using ReFS instead of NTFS) –  s093294 Aug 27 '12 at 15:20
    
@s093294 From the local machine, right click the folder -> properties -> Security tab. –  HopelessN00b Aug 27 '12 at 15:21
    
Everyon has read/list folder marked. So it looks like permissions are set both places. –  s093294 Aug 27 '12 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.