Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\ReservedPorts set to 1153-1153, but sometimes IPv6 programs get assigned this port. Is this setting for IPv4 only? Is their another place to set this for IPv6?

share|improve this question
up vote 1 down vote accepted

Windows Server 2008 and 2008 R2 no longer support the ReservedPorts registry entry.

Instead, use the netsh utility to reserve ports, like so:

netsh int <ipv4|ipv6> Add excludedportrange [protocol=]tcp|udp [startport=]<integer> [numberofports=]<integer> [[store=]active|persistent]

Source: http://support.microsoft.com/kb/2665809/en-us

Edit: You also might need to install the Windows hotfix first found at the above MS Support KB.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.