Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running into an issue with a user whose Word document is somehow turning itself into Read-Only. The user is using Word 2003 and is accessing a document that is in a Server 2008 share. The document itself starts out as a normal, editable document (user has Full Control permissions), and the user is able to save and do the 'normal' things you would do to a document. However, after a couple of saves, the document turns to Read-Only (according to the title bar) even though the Read-Only attribute is not checked on the document's properties.

Here is some additional information about the situation:

*User has approximately 5-8 Word documents open at a time

*User saves the document frequently (sometimes at a frequency of once per minute)

*Once the document is closed it will open as a normal document if reopened

*When the document does turn to Read-Only the user will do a "Save As" on the document and save it as FILENAME # where # is some increment of how many times this has happened (some documents are up to their 30th iteration)

I understand that there is probably some room for user education here and that they could just be copying the RO document to a new one, closing and opening the RO doc, then copying all the information back. However, I would like to get to the route cause of the problem and try to stop it from happening in the first place.


UPDATE: Apparently the reinstall did not fix the issue. I researched the issue a bit more and found that disabling the background save may take care of it, but I haven't had a chance to try it yet. Does anyone else have any other ideas?

share|improve this question
1  
do other users have the same document open? –  Keith Jul 17 '09 at 18:45
    
No--this document is part of this particular user's home network share. –  Psycho Bob Jul 17 '09 at 19:36

5 Answers 5

In the interest of helping you resolve your problem here's a resolution I found at WordTips:

The only way she was able to get around the problem was to turn off the automatic backup file feature in Word (Tools | Options | Save tab, clear Always Create Backup Copy) while working in that document.

Have you considered implementing a real-time office document sharing plugin like DocVerse? Note: As this product is currently in beta it only supports PowerPoint but will support all Office docs in the future. I used it as an example for implementing a more integrated way of sharing docs across a network.

Also, this Read-Only hassle could be related to a network permissions issue as opposed to a document permissions issue since it involves files on the share. I'm assuming the user doesn't experience this issue when they save and edit files locally.

share|improve this answer
    
The documents that the user accesses and saves in this way are not stored locally, so I couldn't speak to that user's ability to work with local documents in the same manner. –  Psycho Bob Jul 17 '09 at 19:39

We started experiencing the same issue with Office 2007 (both Word and Excel docs) a while back. It happened in a number of scenarios, as well. Editing a doc stored locally (both on XP and a Win7 build), a doc stored in SharePoint 2007, a doc on a file share, etc...

Luckily, when we started having this issue, Office 2007 SP2 was only about a week or two away from release. Once it came out, I installed SP2, and since then the issue has not come back (knock on wood).

I know you are running Office 2003, but I would at least make sure its fully patched and see if that helps. Also, check with Microsoft to see if there is a hotfix available that hasn't been released as a standalone patch or rolled into a service pack yet.

share|improve this answer

I know this is old but I'm still getting this on a mapped network drive.

My workaround is to save-as to the same file using the UNC path instead of the mapped path.

share|improve this answer
    
That's not a bad idea. That would have been much easier! –  Psycho Bob Apr 29 '11 at 15:00
1  
Try disconnecting and the remapping the network drive. This seems to have solved it for me. –  CAD bloke May 1 '11 at 8:30
up vote 1 down vote accepted

It appears that going into the normal.dot and disabling background saving does the trick.

share|improve this answer
    
Yes, and one thing to note is that in Office 2010 you need to go to File => Options => Advanced => "Save" Grouping => Uncheck "Allow background saves" –  Michael Perrenoud Sep 4 '12 at 16:54

This problem is not peculiar to Word 2003. I get it on Word 2007 as well, and it occurs on network shares and local files. I found this thread looking for any information about it. I will attempt turning off the "Save Auto-recover Information every.." option, and see if that works. It is ironic that one must turn off the ability to automatically save a document in order to be able to save it on purpose.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.