Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have debian server with postfix and roundcube. After an attack we are on 2 blacklists, but I don't think that this is the main problem. I can't send mail to any address. I tried to find the cause...I checked var/spool/postfix/etc/resolv.conf and resolv.etc and they're the same with this content:

nameserver localhost

In var/log/mail.err I found:

cyrus/imap[25452]: DBERROR: opening /var/lib/cyrus/user/m/ cyrusdb error
cyrus/imap[25452]: DBERROR: skiplist recovery /var/lib/cyrus/user/m/ ADD at 1FC0 exists

When I try to send email from roundcube, I get the message from title. When I send it within opera or any other mail client, It gives nothing, but email is'nt sended. Thank you for any advice.

share|improve this question
Can you provide a log when you actually try to send a message? mail.log instead of mail.err might include more info. The cyrus error is something completely different. – zhenech Dec 25 '13 at 9:54

DBERROR: opening /var/lib/cyrus/user/m/ cyrusdb error DBERROR: skiplist recovery /var/lib/cyrus/user/m/ ADD at 1FC0 exists

It means that the skiplist file is corrupted. As you can see, there is something wrong at 1FC0. Truncate the file at this point, the users mail read state will be valid up to the point of corruption.

First, convert the hex to decimal:

$ echo "ibase=16;1FC0" | bc

Then, using dd command to truncate the file:

# dd bs=1 count=8128
# mv
# mv


share|improve this answer


This file defines which name servers to use.It gives access to the DNS(Domain Name System). Point your nameserver to the correct IP address see more at Here your resolv.conf is pointing to the loopback address that is why your mails are not sending. If your DNS is managed by a DNS hosting service then point your nameserver to that address.

share|improve this answer
I change the loopback address to DNS server provided by my hosting service provider, but nothing changed. Still the same error message. Do I have to restart something after modyfying resolv.conf? – culter Aug 28 '12 at 17:43
yes you have to restart bind after that i.e. run:- service named restart. – achal tomar Aug 28 '12 at 20:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.