Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using OpenWrt Kamikaze 8.09 on a Linksys WRT54g v1.1 router. I just flashed it with default settings and got everything working, except my wireless laptop cannot ping my desktop which is wired to the router. What can I do to fix this? (My desktop can ping other desktops wired to the router)

My routing table:

config 'defaults'
    option 'syn_flood' '1'
    option 'input' 'ACCEPT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'

config 'zone'
    option 'name' 'lan'
    option 'input' 'ACCEPT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'

config 'zone'
    option 'name' 'wan'
    option 'input' 'REJECT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'
    option 'masq' '1'

config 'forwarding'
    option 'src' 'lan'
    option 'dest' 'wan'
    option 'mtu_fix' '1'

config 'redirect'
    option 'src' 'wan'
    option '_name' 'ssh'
    option 'proto' 'tcp'
    option 'src_dport' '22'
    option 'dest_ip' '192.168.1.100'
    option 'dest_port' '22'

config 'redirect'
    option 'src' 'wan'
    option '_name' 'http'
    option 'proto' 'tcp'
    option 'src_dport' '8888'
    option 'dest_ip' '192.168.1.100'
    option 'dest_port' '8888'
share|improve this question

5 Answers 5

By default openwrt bridges the lan and wifi networks. The routing table and iptables rules do not even come into play for traffic between lan <-> wifi.

If you can't ping your desktop from your laptop it is because your desktop does not respond to pings.

share|improve this answer

It would help if you posted the details of the routing table.

Most likely you need to add a rule to forward from the wireless interface to the ethernet switch interface on the IP.

Or similarly through the configuration interface.

share|improve this answer
    
I posted /etc/config/firewall. –  andrewrk Jul 17 '09 at 18:18
    
Your 'forwarding' and 'redirect' rules need creating to allow WLAN->LAN and LAN->WLAN and then the routing table itself needs to be made aware. Im no OpenWRT expert, but talking from a Linux POV. –  Aiden Bell Jul 17 '09 at 18:31

First of all, this looks more like an ACL list than a routing table. Routing tables define subnets and what interface to use to get from one to the other. This config doesn't have any of that beyond labeling zones - and I only see a 'lan' and a 'wan'. Where is the 'wlan'?

Second, are you certain your laptop is in a different subnet from your wired clients? What are the two IP ranges of the wired and wireless subnets? Both of these must be defined on the router for it to be able to route between them.

Third, assuming they are defined, (it would be very strange if the router were handing out wireless IP addresses it was unaware of how to route) ping isn't the best test of connectivity across subnets as it may be blocked by the router/firewall inherently after flashing with default settings. Maybe you could try ssh or something you know you have let through.

share|improve this answer

Please post your routing table - the output from

netstat -r
or similar. The IP addresses of laptop and desktop might be useful too.

As regards Bob's comment on firmware versions and Broadcom wireless, it doesn't work pre 8.09_RC1. 8.09 is after 8.09_RC1, so it works on both (release comes after Release Candidate 1).

(Rep too low to comment on previous answers, so posting as answer).

share|improve this answer

Are you using the White Russian or Kamikaze release? I believe Kamikaze does not support wireless on Broadcom devices.

share|improve this answer
    
Kamikaze most definitely does support wireless on Broadcom devices. –  andrewrk Jul 17 '09 at 18:20
1  
oldwiki.openwrt.org/… NOTE: In pre 8.09_RC1 the wireless part is only supported on the 2.4 Kernel version of Kamikaze. The 2.6 Kernel runs fine on the box, but (because the wl.o driver from Broadcom is only available for 2.4 Kernels and the opensource b43 driver is not ready yet) the wireless does not work if you flash a image with a 2.6 Kernel. (the 8.09_RC1 fixes this issue and wlan works on 2.6) –  Bob Jul 17 '09 at 20:35
    
So I guess if he is using 8.09_RC1 he is good, 8.09 he isn't –  Bob Jul 17 '09 at 20:36
    
It's the opposite. 8.09 RC1 does NOT support my router; 8.09 does. I have it up and running right now. I don't know how you can tell me it's not working. –  andrewrk Jul 19 '09 at 5:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.