Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to receive emails on an Ubuntu 11.04 server running postfix with the Plesk control panel. I can't see the mails even on webmail. I am able to send emails and am not getting any error messages on the email client when I try to receive. Here is the output of the logs:

*tail -f /usr/local/psa/var/log/maillog

Aug 29 10:38:31 cp9 postfix/tlsmgr[3811]: fatal: open database

/var/lib/postfix/smtpd_scache.db: Invalid argument

Aug 29 10:38:32 cp9 postfix/master[27738]: warning: process /usr/lib/postfix/tlsmgr pid 3811 exit status 1

Aug 29 10:38:32 cp9 postfix/master[27738]: warning: /usr/lib/postfix/tlsmgr: bad command startup -- throttling

Aug 29 10:38:36 cp9 pop3d: Connection, ip=[::ffff:196.201.x.x]

Aug 29 10:38:36 cp9 pop3d: IMAP connect from @ [::ffff:196.201.x.x]INFO: LOGIN, user=earle@essentialhuku.co.za, ip=[::ffff:196.201.x.x]

Aug 29 10:38:37 cp9 pop3d: 1346229517.874008 LOGOUT, user=earle@essentialhuku.co.za, ip=[::ffff:196.201.x.x], top=0, retr=0, time=1, rcvd=24, sent=1716, maildir=/var/qmail/mailnames/essentialhuku.co.za/earle/Maildir

Aug 29 10:14:05 cp9 postfix/tlsmgr[1133]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument

Aug 29 10:14:06 cp9 postfix/master[27738]: warning: process /usr/lib/postfix/tlsmgr pid 1133 exit status 1

Aug 29 10:14:06 cp9 postfix/master[27738]: warning: /usr/lib/postfix/tlsmgr: bad command startup -- throttling

Aug 29 10:14:08 cp9 pop3d: Connection, ip=[::ffff:196.201.x.x

share|improve this question
    
Just when users started complaining, I saw the machine was out of disk space. –  Paddington Aug 29 '12 at 9:32
add comment

3 Answers 3

up vote 2 down vote accepted

Are you using Plesk or ISPConfig?

Try rm /var/lib/postfix/smtpd_scache.db

I got this solution by Googling invalid argument sltn postfix. You omitted sltn from this post.

You should add that the problem started when the disk space ran out.

share|improve this answer
add comment

Your problem is that one of postfix components does not start, namely tlsmgr. This should help:

postmap /var/lib/postfix/smtpd_scache

Also, check your configuration:

postfix check
share|improve this answer
    
When I try to start the service via the GUI it fails but does not throw an error –  Paddington Aug 29 '12 at 9:40
    
I have run the commands you suggested but nothing has changed –  Paddington Aug 29 '12 at 9:46
    
..The TLS connection cache is maintained by postfix, and should obviously not be hashed. Read postfix.org/postconf.5.html#smtpd_tls_session_cache_database for details on how to configure it. –  adaptr Aug 29 '12 at 12:30
add comment

I resolved this by mv /var/lib/postfix/smtpd_scache.db rm /var/lib/postfix/smtpd_scache.db.backup. It seem the smtpd_scache.db was the cause of the problem. I got the advise from http://www.howtoforge.com/forums/showthread.php?t=50569

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.