Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to eliminate Logmein costs. Currently, users go through Logmein to access their work desktops from home. I know I can use Remote Desktop Services in Sever 2008 R2 to eliminate this logmein cost and possibly even make it easier for the users. The users only login to their work desktops from home or wherever, on occasion, to use work apps. I think they would really like using RDWeb Remote Apps. Internally, everything works fine. I have the access rules in place in my sonicwall unit to allow external traffic to our RD Session Host Server/gateway/etc., but I think I must have a valid SSL to get access to RDWeb externally. Is that correct? I've tried to access the rdweb link externally, but of course it fails because the address is https://servername.local/rdweb I'm pretty sure the blasted local is keeping me from being able to test this before we purchase a SSL. I've even tried the farm name (that works locally btw), but it still fails.

I have everything in place, but just can't test it externally. Maybe I'm missing something. Like I said earlier, all of it works correctly internally, so I've setup the Remote Desktop Services correctly: licensing, gateway, session hosts, rdweb apps, etc. It's probably just something for the external stuff I'm missing or that I do in fact must have a valid SSL in place for external traffic to get through.

Thanks in response.

I hope this question makes sense

share|improve this question
    
Self sign a certificate. The terminal server client isn't very picky. For the initial testing a self-signed cert is fine. –  Zoredache Aug 30 '12 at 17:00
    
Well then it must be some other barrier. I'm using an alt port for https. I've edited that in IIS, Sonicwall, and the Windows Firewall of the RDS server. All is set correctly in Sonicwall for external access to that server. I wonder what the heck the barrier is? –  AVandelay05 Aug 30 '12 at 18:46

1 Answer 1

up vote 0 down vote accepted

slaps head Doh! I forgot, when testing externally, I can use the external IP in the url. :) I think the ".local" is a barrier when testing externally, maybe I'm wrong, but anyway I was able to make the connection and test externally which is what I wanted to do.

Thanks!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.