Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got the following command with this error

rsync -avz --links -O /home/jansiatest/.jenkins/workspace/svn_to_demo/trunk/CPS/ jansia@ps27670.dreamhost.com:/home/tasklite/temp
sending incremental file list
./
rsync: failed to set permissions on "/home/tasklite/temp/.": Operation not permitted (1)

But the thing is that i don't want to change permission of "/home/tasklite/temp/". How can i set that?

share|improve this question
up vote 5 down vote accepted

Replace -avz with -rltvz. (The -a option is equivalent to -rlptgoD.)

share|improve this answer
    
Thanks man helped me out too. Though i only needed -rltv (not -rltvz) instaed of -av. Since i only used -av and not -avz to begin with :) – Zeroz Sep 10 '13 at 17:37
1  
This is not good advice. Yes, not trying to set permissions will stop it from setting permissions...but if the user wants permissions set then this is just hiding the real problem. I get this error even though the rsync user and target directory are the same user and the files have 777 permissions... – Cerin Dec 21 '15 at 21:13

Adding --no-p disables just permissions setting, leaving all other options setup by -a intact. Another issue often happening is inability to set times this can be sorted by adding -O which you already have in your code

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.