Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Windows Server 2008 R2 running virtualized in a KVM virtual machine.

Recently the virtual machine decided to stop booting, and it offered to Launch Startup Repair. However, upon entering Startup Repair the virtual hard drive was nowhere to be found.

enter image description here

I mounted the Windows Guest Tools ISO image provided by Red Hat Enterprise Virtualization, and then discovered (actually remembered) that Red Hat ships the virtio guest drivers in installable .msi files and not in a format which Startup Repair can use.

How can I make Startup Repair find the disk so that I can complete the repair?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

I needed to find the virtio drivers for Windows already unpacked. It turns out that Red Hat builds exactly such an ISO image for the Fedora Project (and for other KVM users), including signed virtio drivers.

I downloaded a copy of this ISO image and mounted it to the virtual machine. Then I clicked Load Drivers and navigated to the \win7\amd64 folder on the image to select the viostor driver.

enter image description here

At this point it found candidate drivers and I just clicked Add Drivers. I did not find it necessary to select anything in the list.

enter image description here

Finally it loaded the drivers within Startup Repair and I was able to see the virtual hard drive. One problem solved.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.