Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Using a guest VM with Ubuntu, I modified /etc/apache2/ports.conf to listen on port 8010.

After starting mysql and apache2, I went to http://localhost:8010/bugzilla, however I got a 404 error.

I think that my ports.conf is set up correctly since I see a 404 error, "The requested URL /bugzilla was not found on this server" shows up on localhost on port 8010 from the host machine.

Please check out my ports.conf and advise me.

ports.conf

NameVirtualHost *:8010
Listen 8010

#<VirtualHost *:8010>
#DocumentRoot /bugzilla
ServerName bugzilla
ServerAdmin webmaster@localhost

# Other directives here

#</VirtualHost>

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>
share|improve this question

migrated from stackoverflow.com Aug 30 '12 at 23:54

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

you mix too many concepts: port management and DocumentRoot definition.

Here Apache does not find the directory bugzilla in your actual DdocumentRoot. It's not a probleme of port.

Often the documentRoot is in /var/www then bugzilla should be here ; regarding your actual configuration.

edit :

to manage the CGI you will need to add this in your httpd.conf

<Directory /var/www/html/bugzilla/>
AddHandler cgi-script .cgi
Options +Indexes +ExecCGI
DirectoryIndex index.cgi
AllowOverride Limit
</Directory>

the better way is to make a dedicated virtualhost otherwise if you crash your apache config ; every service will be down.

share|improve this answer
    
My apache2's error.log shows "[error] [client 10.0.2.2] File does not exist: /var/www/bugzilla" I updated my /etc/apache2/httpd.conf to look for cgi files at /var/www/html/bugzilla, which is where bugzilla is located. Should I move bugzilla to /var/www/html? –  Kevin Meredith Aug 30 '12 at 14:30
1  
of course. Otherwise how the httpd server will find it ? –  user133014 Aug 30 '12 at 14:37
    
Yea, good point. So localhost/bugzilla only shows perl code, rather than actually displaying it. Is there something I need to do so that the code executes? –  Kevin Meredith Aug 30 '12 at 14:54
    
no ; if you had authorized the execution of cgi in that directory that should be ok. Dont hesitate to look at the installation guide too. But again I recommand to isolate bugzilla on another vhost thus it will be more confortable to manage the config of it ;) good luck –  user133014 Aug 30 '12 at 14:58
    
Thank you for your help. Not sure what I did, but the Bugzilla homepage rendered after I refreshed http::/localhost/bugzilla –  Kevin Meredith Aug 30 '12 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.