Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using two SL6.0 virtual machines on VirtualBox. I want to create a YUM environment. YUM server has been successfully created and the YUM client has also been configured correctly.

But when I run yum list all or yum install packagename* -y on the client, the following error shows up:

ftp://192.168.0.101/rhel6/dvd/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - ""
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: client. Please verify its path and try again

In my attempts to solve this problem I renamed the default files sl.repo and sl-updates.repo to sl.repo.bak and sl-updates.repo.bak, thinking maybe the stuff inside them is creating problems, but to no avail...

I can successfully ping the server. The repo file is correctly configured. From what I have read on the net, this is a pretty common error, and occurs for no apparent reason.

How do I resolve this?

share|improve this question

migrated from stackoverflow.com Aug 31 '12 at 6:27

This question came from our site for professional and enthusiast programmers.

    
Python errors are normally a result of changing the DEFAULT and REQUIRED version of python to something else by manually replacing it.Did you do something like that? –  user1613360 Aug 30 '12 at 8:12
    
No I didn't do that.I think the error has something to do with my ftp connection. –  user1633263 Aug 30 '12 at 8:17

1 Answer 1

up vote 1 down vote accepted

Check your Firewall settings to ensure FTP is not blocked.

share|improve this answer
    
You are right the culprit is the firewall on the server side.Now it works.Thank You very much. –  user1633263 Aug 30 '12 at 8:21
    
That's great.Please don't forget to close the question. –  user1613360 Aug 30 '12 at 8:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.