Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to setup a vSphere Client vCenter v5.0.0 Build 455964 Template Customization Specification using a Windows Sysprep unattended answer XML file for Win2008R2.

However I didn't know how Sysprep worked before attempting this so it was a time-consuming nightmare (even after reviewing VMware vSphere ESXi 5's documentation)! I think I've figure out what I'm supposed to be doing, but it's still not working. The biggest problem at this point is that vSphere Client vCenter Customization Specification IP address information is not sticking when I load a Sysprep XML file with just 1 basic setting! This can only be a bug.

Here is the process I'm using:

PROCESS for Windows - vSphere Client > Install Windows OS > install VM Tools > customize Windows (GPOs can be used to do this after deployment) > install Applications (GPOs can be used to do this after deployment too) > shutdown the VM > convert the VM to a template > create a custom Windows Sysprep XML answer file with desired customizations > View > Management > Customization Specifications Manager > create "New" Specification > for "Target Virtual Machine OS" select Windows > check "Use Custom Sysprep Answer File" (ADDS: Custom Sysprep File. KEEPS: Network (IP), Operating System Options (SID, Sysprep /generalize). REPLACES: Registration Information of Owner Name & Organization, Computer Name, Windows License (Key), Administrator Password, Time Zone, Run Once, Workgroup or Domain) > name it as "VMwareCS-OS####R#x32/64w/Sysprep-TEST" (CS=Customization Specification) > set Description as "Created YYYY/MM/DD by FLast" > NEXT > import a Sysprep answer file from secure location > NEXT > Custom settings > NEXT > click "..." box to right of "Use DHCP" > set "Use the following IP settings:" > for "IP Address" fill out the first 2 octets > set appropriate values for other 2-3 fields > set DNS server addresses > OK > NEXT > check "Generate New Security ID (SID)" ALWAYS as template is likely a domain-member computer so it can be updated occasionally > NEXT > Finish > View Inventory > VMs and Templates > right-click previously completed template > Deploy Virtual Machine from this Template > provide the new OS name (max15char) > select inventory location > NEXT > select Host/Cluster (wait for validation to succeed) > NEXT > select Resource Pool (wait for validation to succeed) > NEXT > select Storage location > NEXT > check "Power on this virtual machine after creation" > select "Customize using an existing customization specification" > select desired specification > select "Use the Customization Wizard to temporarily adjust the specification before deployment" > NEXT > NEXT > Custom settings? > NEXT > check "Generate New Security ID (SID)" ALWAYS as template is likely a domain-member computer so it can be updated occasionally > NEXT > Finish > Finish.

I know a community member named "brian" ( has worked with this scenario before, but I couldn't figure out how to contact him directly, so Brian if you see this message could you provide some information to help?

share|improve this question
You use @ before someone's username to send a notification to their inbox. So @Brian should work... though I don't know how that'll work with you having the same username, honestly. Also, you gotta do something about that wall of text you're trying to pass off as your process. No way I'm reading through that without getting paid for it. Use screenshots or bullet points, or something to make it... something that anyone's willing to read through to help you. – HopelessN00b Aug 31 '12 at 17:37
You need to format that wall of text you have as your process. No one is going to read through that and try to figure out what you are doing. Turn it into a numbered list of steps. Make it easier for us to help you. – Starfish Sep 30 '12 at 5:03
up vote 0 down vote accepted

brian, if you're still out there, it would be great to have feed-back from you.

In regards to the biggest problem with vSphere Client vCenter Customization Specification IP address information not sticking when I load a Sysprep XML file, I confirmed with VMware that it's a known bug since ESX 4.0 ( that causes this problem with WinVista-2008-7-2008R2. The VMware tech support person said this issue was supposed to be fixed in ESX 5.0, but has been pushed back until ESX 6.0, at least. It's just too bad their Customization Specification Wizard doesn't alert you to this issue.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.