Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Access Database Engine 2007 32-bit. The splash screen comes up, you click "Next", then it fails with the error:

Installation ended prematurely because of an error

You click "OK" and another error window says:

The installation of the package failed.

The exact same situation happens when I try this with Access Database Engine 2010 32-bit.

This production server is running Windows Server 2008 R2 SP1 64-bit.

Before I tried installing Access Database Engine 32-bit, I first needed to install Microsoft Office 2010 Pro (Excel and Office Tools only). I tried the 32-bit version on the production server since that is how I set it up in our Dev environment. No luck. The 32-bit version would not install. I did NOT get the error "You have 64-bit components of Office installed". I simply received the exact same two errors listed above. So, I knew that 32-bit/64-bit did not really matter for the Office install for my project, so I installed 64-bit of Office Pro 2010 (Excel and Office Tools only) with no problems.

I have a requirement that I need to have the 32-bit version of the Access Database Engine installed. 2007 or 2010, doesn't matter. I cannot use the 64-bit version of Access Database Engine 2010 because my SSIS package will not work with it. I require the 32-bit version.

I've tried several steps to try to get it installed. I seriously think that the production server has some aversion to installing 32-bit applications. Here's what I've tried:

  • Tried installing via command line with the "/passive" switch....no luck.
  • Tried numerous iterations to copy the install file to the server (downloaded a fresh copy directly to the server, downloaded a fresh copy to my local machine then copied it over, copied it over zipped up) (http://social.msdn.microsoft.com/Forums/en-US/sqldataaccess/thread/efd3c1f0-07cd-45ca-a626-2dd0c7ac3e9f).
  • Tried Method 1 from this link.

    Could not try Method 2 because it requires a server reboot and in my environment that requires a long change management process.

  • I've verified that I am a local administrator on the server. (Evidence, I am able to install other applications (office 64-bit per above)).
  • Verified that there are no other office products that should be blocking the installation. The fore-mentioned install of Excel 2010 64-bit was the first Office product installed on the server.
  • VERY ODD: To test my theory that the production server does not like 32-bit applications, I installed something lightweight. I installed 7-Zip 32-bit on the production server with no problems whatsoever.

Here are some things that I have not tried (i will follow-up once I do):

  • Method 2 (as mentioned above). Requires a server reboot.
  • Have not verified that the Dev and Production environments are 100% identical. I've done a cursory check and on the surface they appear to be the same (same OS and SP version). I need to do a deeper dive to be 100% certain.

I had no problems in my Dev environment. In Dev, I installed Office 2010 Pro 64-bit (Excel & Office Tools only) then via command line w/ the "/passive" switch, installed Access Database Engine 2010 32-bit.

I don't know what else to try. Any suggestions or comments?

share|improve this question
    
I've verified that the Dev server and the Production server are the same. The only difference is that Production has more memory (naturally). I'm still unsure of what to try next or what the problem could be. –  Rayzor78 Aug 31 '12 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.