Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are migrating our .Net 2.0 app from a physical Windows 2003 server with IIS 6 to a virtual Windows 2008 server with IIS 7 (classic). We see that the application is very slow, and most of the time, pages just throw an IIS issue.

We were able to narrow down that the pages that connect to our MSSQL Server 2005 database are causing the problem. If it is a very simple database pull, pages will come after some time. But pages that have a lot of database pulls just hang for a while and throw an IIS error.

Our application server is able to connect to the database server (which is on a different subnet), but it is extremely slow.

However, we are able to connect to the same db server from our old Windows 2003 server.

This issue has been killing us for more than 3 days.

Any help is highly appreciated.

share|improve this question
    
What platform is the VM running on? What's the connectivity look like to the database server - is it on the same network, or in a different location; are the latency and throughput reasonably equivalent to the old server? –  Shane Madden Aug 31 '12 at 18:49
    
VM runs on Win 2008 R2. DB server and the app server are under different subnets --> thats the only difference. Yes, latency is fine. –  PDS Aug 31 '12 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.