Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to run Apache with mod_wsgi to run Python scripts. The server is running Ubuntu 12.04 with Zend Server installed, but when I enable the wsgi module Apache will not start. I get an error message of apache2: apr_sockaddr_info_get() failed in the error log. I installed the module using the Debian package.

I can't seem to find this specific problem anywhere so maybe it's a problem with Zend Server? I'm stumped.

share|improve this question
    
I get an error message of apache2: apr_sockaddr_info_get() failed in the error log. --> please post some lines around this error? –  quanta Sep 1 '12 at 8:50
    
@quanta Starting web server apache2 apache2: apr_sockaddr_info_get() failed for <hostname> apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName ...done. That is the entire entry in the error log. –  Rox45 Sep 1 '12 at 16:38
    
That warning can generally be ignored. –  Graham Dumpleton Sep 3 '12 at 0:14
    
I would normally agree, but it's the only output I'm able to find when I enable the module, and Apache will not start. –  Rox45 Sep 3 '12 at 4:58
    
Run 'apachectl -t' to see if Apache outputs any error messages to the terminal where you run that command. Sometimes if you have missing symbols when it loads up it can silently not start but running '-t' will show you the problem. –  Graham Dumpleton Sep 3 '12 at 5:52
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.