Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My download/upload in server and out of server is too slow (around 50 Kb/s !) !

Did I miss something in my configuration?

Some information:

CentOS release 6.3

uptime

load average: 0.17, 0.32, 0.37

Memory

free -m
             total       used       free     shared    buffers     cached
Mem:         24009      21988       2021          0        806      18098
-/+ buffers/cache:       3083      20926
Swap:         4095         28       4067


lshw -C network
  *-network               
       description: Ethernet interface
       product: 82574L Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 00
       serial: 00:25:90:70:17:4a
       size: 100MB/s
       capacity: 1GB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=off broadcast=yes driver=e1000e driverversion=1.9.5-k duplex=full firmware=2.1-2 ip=108.175.8.123 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:16 memory:fb900000-fb91ffff ioport:e000(size=32) memory:fb920000-fb923fff

ethtool

ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: off
        MDI-X: off
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000001 (1)
        Link detected: yes

dmesg |grep e1000e

dmesg |grep e1000e
e1000e: Intel(R) PRO/1000 Network Driver - 1.9.5-k
e1000e: Copyright(c) 1999 - 2012 Intel Corporation.
e1000e 0000:02:00.0: Disabling ASPM L0s 
e1000e 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
e1000e 0000:02:00.0: setting latency timer to 64
e1000e 0000:02:00.0: irq 33 for MSI/MSI-X
e1000e 0000:02:00.0: irq 34 for MSI/MSI-X
e1000e 0000:02:00.0: irq 35 for MSI/MSI-X
e1000e 0000:02:00.0: eth0: (PCI Express:2.5GT/s:Width x1) 00:25:90:70:17:4a
e1000e 0000:02:00.0: eth0: Intel(R) PRO/1000 Network Connection
e1000e 0000:02:00.0: eth0: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e 0000:02:00.0: eth0: Unsupported Speed/Duplex configuration
e1000e: eth0 NIC Link is Up 10 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e 0000:02:00.0: Disabling ASPM  L1
e1000e 0000:02:00.0: eth0: changing MTU from 1500 to 9000
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
share|improve this question
    
How fast should it be? What are you doing to test - connecting to something locally or over the internet? –  Shane Madden Sep 1 '12 at 19:41
    
wget --output-document=/dev/null speedtest.wdc01.softlayer.com/downloads/test500.zip - 53.2K/s eta 2h 32m - over internet –  Mehdi Sep 1 '12 at 19:45
    
It's a dedicated server from 1and1 company –  Mehdi Sep 1 '12 at 19:46
    
The company said : we guarantee up to a 100Mbit connection from the server to the switches in the data center. Outside of the data center, the bandwidth and connection would be determined by your ISP. –  Mehdi Sep 1 '12 at 20:01
    
What does netstat -i show? –  Nils Sep 1 '12 at 21:16

2 Answers 2

up vote 3 down vote accepted

You set the speed manually to 100 MBit, full duplex, instead of doing auto-negotiation.

Your provider will probably have set auto-neg. Result is that the port on the network-side will drop to 100 MBit halve duplex.

So you have a duplex mismatch here (and possibly many retransmits).

Set it to auto-negotiation - and look again with netstat -i and ethtool.

share|improve this answer
    
Thank you very much :), it works now –  Mehdi Sep 1 '12 at 21:44

This line:

e1000e 0000:02:00.0: eth0: changing MTU from 1500 to 9000

Is somewhat concerning. The MTU between that server and any random spot on the internet is practically guaranteed to be no higher than 1500, so it getting set higher is not a good thing. I hope that wasn't a troubleshooting step, because that kind of config can only hurt performance.

You sometimes see that setting in VMWare hosts on a virtual-switch, but this is supposedly physical hardware.

You can verify the MTU setting of your adapter through ifconfig eth0, it will be listed.

To set it back to 1500 on CenOS, change /etc/sysconfig/network/ifcfg-eth0; there will be an MTU line in there if it's set to 9000.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.