Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed this tut http://www.trainsignal.com/blog/how-to-set-up-safe-ftp-in-linux to setup an ftp server with user account

sudo mkdir -p /home/ftp/ftpuser
sudo useradd ftpuser -d /home/ftp/ftpuser -s /bin/false
sudo passwd ftpuser

when I tried to connect with login ftpuser remotely it didn't work. It didn't work even with root UNLESS I removed root from ftpusers.

I am confused ftpusers are the users NOT allowed to do ftp ? Where are the list of users allowed then and why can't I connect with ftpuser I created ?

share|improve this question
    
Can you post your ftp server config? –  Khaled Sep 2 '12 at 11:12
    
Also post the error message you get when trying to log in. –  Ansgar Wiechers Sep 2 '12 at 11:55

2 Answers 2

Yes, somewhat confusingly the /etc/ftpusers file is a list of users who are not allowed to use the FTP service.

To answer your other question, we will need more information. Offhand, I wonder if perhaps you forgot to uncomment the local_enable=YES option. Please share the error you receive on the ftp client, any relevant errors from syslog, and your configuration if you could.

share|improve this answer

Your second option is to setup an SSH account for the user and have them connect to SFTP on port 22.

You would go through the same setup as above with the exception

sudo useradd ftpuser -d /home/ftp/ftpuser -s /bin/bash

This gives the user both SSH and SFTP access via any FTP application such as Filezilla via port 22(or your SSH port if you have changed it)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.