Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a followup question to Cannot mount /dev/sdc1 on Debian 5.0, special device /dev/sdc1 doesn't exist

Basically, I have 6 SATA hard drives in a machine and I'm trying to create a RAID6 array with them. When I try to run the mdadm command to create (with the verbose option) a raid array, I see messages like "mdadm: super1.x cannot open /dev/sdf1: No such device or address" which are resolved by doing partprobe /dev/sdf and then re-running the mdadm command.

The problem is that I have to run partprobe after each reboot, and from experience I don't think this is normal behaviour -- on no other linux machine do I have to partprobe the device before I can use it. Something must be going wrong, but how do I troubleshoot this to find out what? Could this be caused by a hardware problem?

Edit: Additional note - before I seemed to only have this problem with one drive, but now I'm having it with 3 drives.

share|improve this question
What do the logs say? – Michael Hampton Sep 3 '12 at 1:45
Particularly what does dmesg say about assembling the RAID? – Ansgar Wiechers Sep 3 '12 at 1:49 dmesg output – Jeff Welling Sep 3 '12 at 2:25

It looks like the kernel is trying to add a whole drive into the array instead of the partition. Had you created an array using the whole drives before you created it using the partitions? If so, maybe md is seeing two superblocks.

Edit /etc/mdadm/mdadm.conf and add:

DEVICE /dev/sda1
DEVICE /dev/sdc1
DEVICE /dev/sdd1
DEVICE /dev/sde1
DEVICE /dev/sdf1
DEVICE /dev/sdg1
share|improve this answer

If you are using partprobe, chances are you might be using a gpt partition table. I ran into the same problem and it turned out my kernel didn't have support for it. What happens in that case is that the partition table is off, and raid autodetection fails. Running partprobe seems to temporarilly fix the issue

Make sure your kernel has support for gpt, ie CONFIG_EFI_PARTITION=y

share|improve this answer
Perhaps you could elaborate your answer a bit as to why? – slm Jul 10 '13 at 11:21
Hi. Tried to give a little more insight on my answer. Just wanted to share on what fixed the problem for me. – Benjamin Jul 10 '13 at 11:57
Yeah sharing is good, just wanted it to be clear to the OP and others that might come across your answer in the future so that it's clear to all. Looks much better, thanks. – slm Jul 10 '13 at 12:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.