Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have an issue where I have installed new certificates on Centos 5 and modified the conf file for the following lines:

SSLCertificateFile /etc/pki/tls.certs/name.crt

SSLCertificateKeyFile /etc/pki/tls/private/name.key

SSLCACertificateFile /etc/pki/tls/certs/group.ca-bundle

But everytime i start the httpd service i get the following:

>     sudo service httpd start
>     Starting httpd: Apache/2.2.15 mod_ssl/2.2.15 (Pass Phrase Dialog)
>     Some of your private key files are encrpyted for security reasons.
>     In order to read them you have to provide the pass phrases.
>     Server servername.co.uk: 443 (RSA)
>     Enter pass phrase:
>     OK: Pass Phrase Dialog successful.                     [FAILED]

(Only have basic knowledge with CentOS, so please excuse me for my stupidity in advance!)

So question is what is failing? And where can i find the relevant logs to tell me this?

share|improve this question
    
Is there any extended information about this in the Apache logfiles? –  pkhamre Sep 3 '12 at 10:26
    
Have take a look at almost every logs in /var/log folder but don't even see any logs created for them. This server has been handed down with zero documentation unfortunately! –  Cold T Sep 3 '12 at 10:32
    
Enable debug logging and check if any of the debug logs contain any interesting data. –  pkhamre Sep 3 '12 at 10:35
    
Have enabled the debug option but cannot see any logs being recorded. At a complete loss here! –  Cold T Sep 3 '12 at 10:58
    
What if you run the httpd binary manually? With httpd -e debug –  pkhamre Sep 3 '12 at 11:10

2 Answers 2

up vote 0 down vote accepted

Run the httpd binary manually with the debug-loglevel to see if you can get any more information from it.

httpd -e debug

share|improve this answer

Two possible solutions:

  1. Use certificate pass phrase from certificate
  2. Add pass phrase to your apache configuration - see https://httpd.apache.org/docs/2.2/mod/mod_ssl.html#sslpassphrasedialog
share|improve this answer
    
OP quoted: "OK: Pass Phrase Dialog successful.". So I would assume that this problem has nothing to do with the pass phrase. –  pkhamre Sep 3 '12 at 10:27
    
I am using the pass phrase, that is entered correctly as you can see from the above output. Placing pass phrase in apache config file is a massive security risk for the certs. –  Cold T Sep 3 '12 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.