Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my localhost ( http://hotel.local/ ) everything works ok (Max OSX). Now I installed a Virtual Machine for testing my application on IE8.

The fact is that from this virtual machine if I tried to open this application it keeps asking to save a php file instead of opening. If I tried from Chrome for example, it works correctly.

Any help or clue?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

This is a coding issue, not a server or browser issue. You need to ensure you're sending the correct headers. Some browsers are more accommodating of bad code than others.

share|improve this answer
    
It is possible, in fact, the site uses jQuery Mobile so maybe that the problem. –  Kioko Kiaza Sep 3 '12 at 19:28
    
jQuery, Mobile or otherwise, isn't a factor. It just comes down to sending the correct headers, which needs to be coded in. –  John Gardeniers Sep 4 '12 at 0:25
    
it was headers problem. Thx!! –  Kioko Kiaza Sep 4 '12 at 6:43
add comment

Check your httpd.conf. PHP is probably not being parsed. Make sure you have the type set:

AddType application/x-httpd-php php

And you use the correct Modules & Handlers:

LoadModule php5_module        modules/libphp5.so
AddHandler php5-script        php 
share|improve this answer
    
I´ve got this configurations. In chrome works perfect, on IE8 it shows "Save file" dialog. –  Kioko Kiaza Sep 3 '12 at 12:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.