Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After successfully installing Nagios core 3.4.1 (i also installed plug-in1.4.11) on our linux rhel 5.3 server i cannot login to the nagios web interface.I am running apache 2.2.3

I am using internet explorer 8 and also firefox 3.6.3

When i try to enter the url http//localhost/nagios/ on a desktop (on the same network as the Nagios server)it does seem to like

it but if i try

http//x.x.x.x/nagios/ (where x.x.x.x is the IP address of my nagios server) it likes it but then the authentication popup appears

after entering the password and username(nagiosadmin) it throws the errors below

The server x.x.x.x at Nagios access requires a username and password

Warning  this server is requesting   that your username and password  be sent in an insecure 
manner(basic authentication without a secure connection)

After a few attempts i get error 401 authentication required error from internet explorer ;this server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials or your browser doesnt understand how to supply the credentials required.

Help Please anyone..seems like an authentication issue

share|improve this question

Sorry i fixed my own problem just 30 mins after i post this thread ...i changed the permissions on htpasswd.users file it was owned by root.I changed it to be readable by nagios user..depends on your preference you can keep it owned by root and chmod it to make it readable by ALL or chown it such that its owned by nagios ..i just "chmodded" mine to make it readable by nagios user and Bingo it worked..

share|improve this answer

First, you need to make sure you have installed all required nagios packages like nagios3, nagios3-core, and nagios3-cgi. I am not sure whether all of these are found on redhat as I am running Ubuntu. I mean you need to make sure you did not miss any required package.

If you are still not able to login, you can look at apache configuration and use htpasswd tool to add new username/password to be authorized. You need to find a file like /etc/nagios3/htpasswd.users. This may also be different on redhat. You can recreate the file or create another username/password.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.